can't remove sites from cookies sites list

VERIFIED DUPLICATE of bug 92444

Status

()

Core
Networking: Cookies
--
major
VERIFIED DUPLICATE of bug 92444
17 years ago
13 years ago

People

(Reporter: The Anarcat, Assigned: Stephen P. Morse)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1+) Gecko/20010618
BuildID:    2001061804

In the cookies manager, the "cookies sites" tab, I cannot remove the sites
listed there.

Actually, the buttons "remove" and "remove all" *seems* to work (ie. the  item
is removed or the list emptied) *but*, when I open it again, all the sites are
still there.

Reproducible: Always
Steps to Reproduce:
1.remember cookies settings from a site
2.open the cookies sites manager
3.remove one, many or all of the cookies sites there
4.close the manager
5.open it up again to see the list all there

Actual Results:  Cookies sites still live.

Expected Results:  Cookies sites should DIE.

I originally noticed the problem on 0.9.1, and confirmed it on a later nightly
build.

Comment 1

17 years ago
Anarcat, keep in mind that you must hit the OK button in order for your changes
to take effect. Just closing the window or hitting cancel will, in effect,
cancel your changes.

Please test this again hitting the OK button after making your changes.
(Reporter)

Comment 2

17 years ago
I swear I *did* clicked the OK button.

[Workaround]
I tried removing the big cookperm.txt file I had here, and it effectively
emptied the list. 

Now, I can remove whatever cookie sites I put in there, oddly enough. I will try
again when I will have enough entries in the list. The only problem is that each
time I test this, the list empties itself. ;)
(Reporter)

Comment 3

17 years ago
Ok. I just tried a test dry run here at home with 2001061804, and
having just a single cookie site in the list, I could remove it using
remove or remove all.

So I could not reproduce the bug on Win98/2001061804. And not on
2001062815/WinNT either.

The thing is that my other test case featured a pretty big list of
cookies sites... Maybe that's related?

And yes, I swear I tried "OK" and not cancel. I mean, come on... :)

Comment 4

17 years ago
Ok, if you can reproduce again, please post some new "steps to reproduce." If
not, I'll go ahead and resolve this bug.
marking worksforme. (wfm with win2k build 20010715..
We can't reproduce this :-(
Reporter: Please open a new bug if you see this again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
vrfy. I've been able to delete stuff out of my list of hundreds of sites...
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

17 years ago
I have been able to reproduce a similar behavior in the image site list. See bug
92449. 

Replacing the 1s by 0s in the cookperm.txt file leads to a similar bug. Clicking
"remove all" makes an incremental phenomenon where the sidebar scroller gets
bigger and bigger while the "remove all" button is pushed down and the sidebar
finally disappears when the "remove all" button gets back to normal. After
clicking OK, returning to the manager (cookies site manager) gives a
non-empty-yet-incomplete list. See attach.

I hope this will be enough to confirm this bug. Try the attachement of bug 92449
and replace all 1s by 0s, reload moz and see what happens. :)
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

17 years ago
Created attachment 43687 [details]
what remains after re-opening the cookies manager
(Reporter)

Comment 9

17 years ago
Wow... That second paragraph didn't make much sense. Let's see:

> ...gets back to normal. 

The list now seems empty.

> After
> clicking OK, returning to the manager (cookies site manager) gives a
> non-empty-yet-incomplete list. See attach.

Yes. That's about right. When reloading the manager, there is still a list,
cookies seems to have been removed, but not all. Also, when the cookie sites
left are simply *unremovable*.

Comment 10

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
(Assignee)

Comment 11

17 years ago
The reason you saw the problem sometimes and not other times depends on whether 
or not you also had a list of images that were being blocked.  In any case, it's 
a dup and there's already a patch available to fix it.  Will get checked in just 
as soon as the tree reopens again.

*** This bug has been marked as a duplicate of 92444 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 12

14 years ago
V/dupe.
QA Contact: tever → benc

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.