TEST-UNEXPECTED-FAIL | /tests/dom/media/tests/mochitest/test_getUserMedia_gumWithinGum.html | Unexpected callback with message = 'undefined' at: ["@http://mochi.test:8888/tests/dom/media/tests/mochitest/test_getUserMedia_gumWithinGum.html:45|

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({assertion, intermittent-failure, regression})

Trunk
x86
Mac OS X
assertion, intermittent-failure, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia][blocking-gum-], URL)

(Reporter)

Description

6 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-3 on 2013-06-17 09:21:59 PDT for push 07708c9fc5ef

slave: talos-r4-snow-080

ERROR TEST-UNEXPECTED-FAIL | /tests/dom/media/tests/mochitest/test_getUserMedia_gumWithinGum.html | Unexpected callback with message = 'undefined' at: ["@http://mochi.test:8888/tests/dom/media/tests/mochitest/test_getUserMedia_gumWithinGum.html:45",""]

https://tbpl.mozilla.org/php/getParsedLog.php?id=24236081&tree=Mozilla-Inbound

Assertion failure: aSource->mDuration >= 0, at ../../../content/media/MediaSegment.h:224

perating system: Mac OS X
09:36:11     INFO -                    10.6.8 10K549
09:36:11     INFO -  CPU: amd64
09:36:11     INFO -       family 6 model 23 stepping 10
09:36:11     INFO -       2 CPUs
09:36:11     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
09:36:11     INFO -  Crash address: 0x0
09:36:11     INFO -  Thread 33 (crashed)
09:36:11     INFO -   0  XUL!mozilla::MediaSegmentBase<mozilla::VideoSegment, mozilla::VideoChunk>::AppendFromInternal(mozilla::MediaSegmentBase<mozilla::VideoSegment, mozilla::VideoChunk>*) [MediaSegment.h:07708c9fc5ef : 224 + 0x0]
09:36:11     INFO -      rbx = 0x00007fff703292f8   r12 = 0x00000001001076d0
09:36:11     INFO -      r13 = 0x000000010c9108d0   r14 = 0x0000000114622b90
09:36:11     INFO -      r15 = 0x0000000001ef3079   rip = 0x00000001023603f6
09:36:11     INFO -      rsp = 0x0000000116080b20   rbp = 0x0000000116080b30
09:36:11     INFO -      Found by: given as instruction pointer in context
09:36:11     INFO -   1  XUL!mozilla::TrackUnionStream::CopyTrackData(mozilla::StreamBuffer::Track*, unsigned int, long long, long long, bool*) [TrackUnionStream.h:07708c9fc5ef : 259 + 0x8]
09:36:11     INFO -      rip = 0x0000000102358be8   rsp = 0x0000000116080b40
09:36:11     INFO -      rbp = 0x0000000116080bf0
09:36:11     INFO -      Found by: stack scanning
09:36:11     INFO -   2  XUL!mozilla::TrackUnionStream::ProduceOutput(long long, long long) [TrackUnionStream.h:07708c9fc5ef : 71 + 0x1f]
09:36:11     INFO -      rip = 0x0000000102358327   rsp = 0x0000000116080c00
09:36:11     INFO -      rbp = 0x0000000116080cd0
09:36:11     INFO -      Found by: stack scanning
09:36:11     INFO -   3  libSystem.B.dylib + 0x3ac4c
09:36:11     INFO -      rip = 0x00007fff81aa5c4d   rsp = 0x0000000116080c10
09:36:11     INFO -      rbp = 0x0000000116080cd0
09:36:11     INFO -      Found by: stack scanning
09:36:11     INFO -   4  XUL!mozilla::MediaStreamGraphImpl::UpdateBufferSufficiencyState(mozilla::SourceMediaStream*) [MediaStreamGraph.cpp:07708c9fc5ef : 196 + 0x6]
09:36:11     INFO -      rip = 0x000000010234d800   rsp = 0x0000000116080c70
09:36:11     INFO -      rbp = 0x0000000116080cd0
09:36:11     INFO -      Found by: stack scanning
09:36:11     INFO -   5  XUL!mozilla::MediaStreamGraphImpl::RunThread() [MediaStreamGraph.cpp:07708c9fc5ef : 1083 + 0x16]
09:36:11     INFO -      rip = 0x0000000102350cc4   rsp = 0x0000000116080ce0
09:36:11     INFO -      rbp = 0x0000000116080dc0
09:36:11     INFO -      Found by: stack scanning
09:36:11     INFO -   6  libnss3.dylib!PL_CompareStrings + 0x8
09:36:11     INFO -      rip = 0x0000000100423909   rsp = 0x0000000116080cf0
09:36:11     INFO -      rbp = 0x0000000116080dc0
09:36:11     INFO -      Found by: stack scanning

Comment 1

6 years ago
This is not Web Audio related.
Component: Web Audio → WebRTC
QA Contact: jsmith
Looks like a recent regression. 

Roc - Any ideas?
Component: WebRTC → WebRTC: Audio/Video
Flags: needinfo?(roc)
Keywords: regression
Whiteboard: [getUserMedia][blocking-gum-]
It looks like 'segment' in TrackUnionStream::CopyTrackData was null, but I can't see how, unless it was OOM, but the allocation we do there ("map->mSegment = aTrack->GetSegment()->CreateEmptyClone();" in AddTrack) is a very small one.
Flags: needinfo?(roc)
(OrangeWFM for bugs not modified in > 2 months)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Depends on: 971740
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
The last few are bug 989047.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.