[Reset Firefox] Select which data to preserve/recover (advanced options)

RESOLVED WONTFIX

Status

()

Firefox
Migration
--
enhancement
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: Florian Bender, Unassigned)

Tracking

(Blocks: 2 bugs)

24 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
(In reply to Florian Bender from Bug 819859 comment #3)
> IMHO there should be an "Advanced" button which lets you select the type of
> data you want to preserve, and which you don't. This will also allow for not
> preserving anything at all.

Here's an example UX design: 

1. User clicks "Reset Firefox", opens dialogue:

=================================
Are you sure …?

Firefox will try to recover the following data: 
• Your Bookmarks
• Your browsing history
• Saved passwords 
• …

Firefox will not recover and fully discard the following data: 
• Addons
• Currently opened tabs and tab groups
• Personal settings
• Website preferences
• Customizations and Themes
• …

[Let me chose what to preserve]  [Cancel]  [Reset Firefox to factory defaults]
=================================

2. User clicks [Let me chose what to preserve], changes the dialogue into the following: 

=================================
Choose what data Firefox should try to recover when resetting your profile:
[X] Your Bookmarks
[X] Your browsing history
[X] Saved passwords
[X] …
[ ] Addons
[ ] Currently opened tabs and tab groups
[ ] Personal settings
[ ] …

[Use recommended defaults]   [Use the selection above]
=================================

3. User selects "Addons" and "Currently opened tabs and tab groups", and deselects "Your browsing history". 

3. a) User clicks [Use defaults]. This will return him to the screen under [1] with no changes made to the selection. 

3. b) User clicks [Use the selection above]. This will show a confirm screen that is actually the modified screen under [1]. 

=================================
Are you sure …?

Firefox will try to recover the following data: 
• Your Bookmarks
• Saved passwords 
• Currently opened tabs and tab groups
• …

Firefox will disable but still try to recover the following: 
• Addons

Firefox will not recover and fully discard the following data: 
• Your browsing history
• Personal settings
• Website preferences
• Customizations and Themes
• …

[Let me chose what to preserve]  [Cancel]  [Reset Firefox to factory defaults]
=================================

4. User clicks [Reset Firefox to factory defaults]. Day seized. 


Wording may be a bit verbose, but (a) I wanted to be as precise as possible, (b) there is no reason to be less precise when this ships because the user triggers a destructive operation here. 


Also, you can see that the user decided to keep the addons via ticking the checkbox, but the reset tool will disable all of them automatically (and tells the user what it is about to do). This should be covered as a follow up, though. (I thought I've seen a discussion about preserving addons, with reasons for and against it. The main point against it was that addons are the culprit of most broken Firefox profiles and thus should not be restored automatically. The UX design above provides a possible solution with not restoring addons by default, and even if restoring them, they will be disabled.)
(Reporter)

Updated

5 years ago
Blocks: 851364
See Also: → bug 819859

Updated

5 years ago
Component: Untriaged → General

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Component: General → Migration
(Reporter)

Updated

5 years ago
Blocks: 891095
This sounds too complicated, and not useful to the target audience for the feature (not-power-users). I'm inclined to WONTFIX.
(Reporter)

Comment 2

5 years ago
IMO, the proposal is not more complicated than many other dialogues not-power-users face (e. g. an Install wizard). This is also something people will not regularly do, so it's OK to be a bit verbose here – while being descriptive and helpful, and providing other ways the user can get help (e. g. link to an offline SUMO article). 

To appeal more to not-power-users, some (less relevant) information can be hidden behind a "see more" (for the first dialogue). The options to choose which data to keep and which not is already hidden behind a "Customize" button. 

My proposal is very verbose to showcase the possibilities. To make it less ALL-THE-THINGS, the number of options can be reduced (e. g. always migrating open tabs), however then I'd like to have a "Gimme a clean slate" option ("[ ] Delete all the above and everything else except Firefox itself.").

Updated

4 years ago
Blocks: 950073
Whiteboard: p=0

Updated

4 years ago
Depends on: 982327
Going to WONTFIX this per comment 1 - I just don't think there's enough user value here to be worth the trouble.

Thanks for the suggestion anyhow, Florian.
No longer blocks: 950073
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
No longer depends on: 982327

Updated

4 years ago
Whiteboard: p=0
You need to log in before you can comment on or make changes to this bug.