Closed Bug 884059 Opened 7 years ago Closed 7 years ago

Developer console can display messages in non-chronological order

Categories

(DevTools :: Console, defect, P3)

18 Branch
x86
All
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 755555

People

(Reporter: kats, Unassigned)

References

Details

Attachments

(1 file)

Attached image Screenshot of console
See the last two entries in the attached screenshot. The timestamp on the last one is *before* the timestamp on the one above. This shouldn't happen, the entries should always be in chronological order.
Thanks for the report. This behavior is known. I am not sure if this is really a bug. Messages arrive async and there is no guarantee in which order they arrive. Also, there is no sorting happening client-side, except at the time of opening in the console - cached messages are retrieved, sorted and displayed.

Other consoles do not display the time for each message, making this behavior less obvious. We will probably go in a similar direction.
Depends on: console-output
OS: Mac OS X → All
Priority: -- → P3
Looks like the underlying problem is the same as in bug 755555.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755555
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.