[valgrind] uninitialized event passed to updateVideoPref

RESOLVED FIXED in mozilla24

Status

()

Core
WebRTC: Signaling
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rillian, Assigned: ehugg)

Tracking

Trunk
mozilla24
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC][blocking-webrtc-], URL)

Attachments

(1 attachment)

Trying to reproduce bug 882589 (crash on cubeslam.com) I got the following valgrind report from the ccprovider code:

==8537== Thread 20:
==8537== Conditional jump or move depends on uninitialised value(s)
==8537==    at 0x9C84FCD: updateVideoPref (ccprovider.c:532)
==8537==    by 0x9C8529B: processSessionEvent (ccprovider.c:640)
==8537==    by 0x9C88E9F: ccp_handler (ccprovider.c:1956)
==8537==    by 0x9C847AF: CCApp_task (ccapp_task.c:184)
==8537==    by 0x390B807D13: start_thread (pthread_create.c:309)
==8537==    by 0x390B0F168C: clone (clone.S:115)
==8537==

Updated

5 years ago
Whiteboard: [WebRTC][blocking-webrtc-]
(Assignee)

Comment 1

5 years ago
Created attachment 766105 [details] [diff] [review]
Signaling - stop setting video prefs when in SDP mode
(Assignee)

Comment 2

5 years ago
Comment on attachment 766105 [details] [diff] [review]
Signaling - stop setting video prefs when in SDP mode

Review of attachment 766105 [details] [diff] [review]:
-----------------------------------------------------------------

I think the simplest fix would be to stop setting the video prefs since they are unused when in sdpmode.  A more complete fix might be to remove them all together since I'm doubtful they would still be relevant even if we turned on the rest of the code.  Take a look at fsmdef.c:852 to see what I'm talking about there.
Attachment #766105 - Flags: review?(rjesup)
(Assignee)

Updated

5 years ago
Assignee: nobody → ethanhugg

Updated

5 years ago
Attachment #766105 - Flags: review?(rjesup) → review+
(Assignee)

Comment 3

5 years ago
Try run to double-check mochitests on other platforms:

https://tbpl.mozilla.org/?tree=Try&rev=c5f1b0ddcd86

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/d3f627a6273e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25

Comment 6

5 years ago
This landed on mozilla-central whilst it was still mozilla24, however mcMerge references the bugzilla target milestone field ordering, which was updated pre-emptively before the merge had occurred.
Target Milestone: mozilla25 → mozilla24
You need to log in before you can comment on or make changes to this bug.