Wierd locatin bar widbet behavior

VERIFIED DUPLICATE of bug 78268

Status

SeaMonkey
Location Bar
VERIFIED DUPLICATE of bug 78268
17 years ago
10 years ago

People

(Reporter: Michal 'hramrach' Suchanek, Assigned: Alec Flett)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I copied this URL into location bar after fom log after a browser crash:
http://bugzilla.mozilla.org/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=&emailtype1=substring&emailassigned_to1=1&email2=&emailtype2=substring&emailreporter2=1&bugidtype=include&bug_id=&changedin=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&product=Browser&component=Networking&short_desc=search&short_desc_type=allwordssubstr&long_desc=&long_desc_type=allwordssubstr&bug_file_loc=&bug_file_loc_type=allwordssubstr&status_whiteboard=&status_whiteboard_type=allwordssubstr&keywords=&keywords_type=anywords&field0-0-0=noop&type0-0-0=noop&value0-0-0=&cmdtype=doit&namedcmd=Any&newqueryname=&order=Reuse+same+sort+as+last+time
Interestingly I was given the option to search for this by Google (my preferred
search) in a pulldown menu.
Expected: fully specified URL should not be searched
When I wanted to delete the thin again I wanted to use Home,C-K. But Home key
moved cursor to the beginning of the text box, not the contained text so I had
to use C-K quite a few times.
Expected: move to start of the text

BTW is there anywhere documantation of the keyboard shortcuts in different
widgets? I think the whole lot became a bit messy. The same key combo sometimes
does quite different things depending on active widget.

Comment 1

17 years ago
Actually, Google allows searches on URLs. For example:
http://www.google.com/search?q=http%3A%2F%2Fwww.mozilla.org&sourceid=mozilla-search

Comment 2

17 years ago
-> URL Bar
Component: XP Toolkit/Widgets → URL Bar

Comment 3

17 years ago
I think this is a won't fix as it is a feature that is useful (i.e. access a
page that is down using google's cache)
--> xpapps. nothing to do with core widgetry.
Assignee: trudelle → alecf
QA Contact: aegis → claudius
(Assignee)

Comment 5

17 years ago
I agree, if anything this is a dupe of the "provide option to disable search in
dropdown" or whatever that bug is called... but we still want this capability to
exist.
(Reporter)

Comment 6

17 years ago
I personally don't mind the search option for the URL, it's just confusing (and
even more confusing with Search button without any Go There button). 
It would be a good idea to write somewhere what's this option good for.

I didn't find any documentation saying what different key combos are supposed to
do inside different widgets. I don't know if the current behavior of location
bar is incorrect but it's unexpected. This is possibly more lack of
documantation than lack of funcionality.

Comment 7

17 years ago
Dupe of bug 80497 which is a dupe of 78268

*** This bug has been marked as a duplicate of 78268 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.