Thimble projects made on mofoprod.net still point at mofoprod.net

RESOLVED WONTFIX

Status

Webmaker
Thimble
--
blocker
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: jbuck, Assigned: pomax)

Tracking

Details

(Reporter)

Description

5 years ago
Projects published on makes.org while thimble was hosted on mofoprod.net still have the make details page pointing at mofoprod.net. It'd be nice to republish all the thimble projects currently on prod so that they get all the new webmaker.org goodness.

Updated

5 years ago
Severity: normal → blocker

Updated

5 years ago
Depends on: 884174
(Reporter)

Updated

5 years ago
Duplicate of this bug: 884213
(Assignee)

Comment 2

5 years ago
Is there a way we can batch-update makes? If not, can we make that happen anyway through a script or a tiny dedicate node app or something?
Flags: needinfo?(chris)
(Reporter)

Comment 3

5 years ago
Easiest way to fix this would be to hack together a file based on the publish route that republished everything.

The crappy part is that all the data you need to republish a thing isn't saved in the database...
I'm not sure what I can offer here, I'd have to dig into thimbles publishing system to understand what needs to be done.
Flags: needinfo?(chris)
(Reporter)

Updated

5 years ago
Assignee: nobody → pomax
Status: NEW → ASSIGNED
(Assignee)

Comment 5

5 years ago
This basically requires people to republish their pages so the S3 link for them points to webmaker.org instead of mofoprod. Is there a way to query S3 for pages with a "refresh" tag that points to mofoprod?
(Assignee)

Comment 6

5 years ago
Is this still relevant? I only see projects from webmaker.makes.org on the front page now, and hitting remix takes all of these to thimble.webmaker.org
(Assignee)

Comment 7

5 years ago
at this point the only use case in which this will happen is the content team running into a project that has not yet been republished, which is easily solved. Everything else looks good.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

5 years ago
Just a nit, it's WONTFIX because we're not going to make a code fix. It's still a valid bug :)
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.