Can't access myMakes in thimble

RESOLVED FIXED

Status

Webmaker
Thimble
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: brett, Assigned: jbuck)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 763985 [details]
mymakes error thimble

May be due to DNS propigation or what not, but I'm not able to access myMakes in thimble. See screenshot
(Reporter)

Comment 1

5 years ago
This is making it impossible to republish thimble makes, which is point people to the wrong server
Blocks: 884173
Severity: normal → blocker

Comment 2

5 years ago
this looks like a first time login issue. if I log for the first time, 'my makes' won't work because webmaker.org doesn't have a persona session cookie set yet, and the 'my makes' data comes from webmaker.org/me?app=thimble... If I go to webmaker, which auto logs me in, and then reload thimble and hit 'my makes', it works.

Can we do an iframe-load for the base webmaker.org site so that the webmaker.org-local-cookie gets set on a firs time login?
Not sure if this helps, but I'm not seeing my makes, and I've logged in and out multiple times. I just tried to publish a make I'd already tried to publish and got an error:

http://imgur.com/Sy40WZ5

but I don't see this in mymakes.
Jon, this has to do with "www" appearing for webmaker.org, which is throwing off our audience params.
Assignee: pomax → jon
(Assignee)

Comment 5

5 years ago
Alright, I need a forced redirect from www.webmaker.org to webmaker.org .

:jp I did this by creating a new instance, putting the following ngxinx config on it:

server {
    listen 80;
    rewrite ^(.*) https://webmaker.org$1 permanent;
}

Then spinning up a new ELB (www-webmakerorg-production) with our san webmaker cert on it. Quick hacks ftw!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=884174#c5 has a mess that needs a cleanup.
(Assignee)

Updated

5 years ago
Blocks: 884523
You need to log in before you can comment on or make changes to this bug.