GStreamer MP3 playback fails since Aurora 23 on Google Music

RESOLVED DUPLICATE of bug 911837

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 911837
5 years ago
5 years ago

People

(Reporter: wolfiR, Unassigned)

Tracking

({regression})

23 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
I'm running Firefox (desktop) with gstreamer enabled since some versions.

Recently had Firefox 22b4 running with no problems when using Google Music (with the HTML5 option turned on to output via <audio> instead of Flash).

On exactly the same system I'm now running Firefox 23 Aurora (built two days ago) but Google Music does not work anymore for me. It looks like it's endlessly loading and only starts playing when I disable HTML5 output to use Flash again. This is obviously an own build since gstreamer is not turned on yet for these versions.

Only playback seems to be affected. Detection is working fine according to html5test.com where MP3 support (and H.264) is "yes".
(Reporter)

Comment 1

5 years ago
Ok, turned out that H.264 is playing fine as well as another MP3 test (http://hpr.dogphilosophy.net/test/).
So actually only MP3 on Google Music is not working for me. Adjusted summary.
Summary: GStreamer playback fails with Aurora 23 → GStreamer MP3 playback fails with Aurora 23 on Google Music

Comment 2

5 years ago
(In reply to Wolfgang Rosenauer [:wolfiR] from comment #1)
> Ok, turned out that H.264 is playing fine as well as another MP3 test
> (http://hpr.dogphilosophy.net/test/).
> So actually only MP3 on Google Music is not working for me. Adjusted summary.

Can you define what it means for "Google Music" to not be working? Is this some webapp?
(Reporter)

Comment 3

5 years ago
Sorry, thought this is known everywhere.
music.google.com is a personal music cloud (and shopping) service which by default uses Flash to play your music but it can be set to use "HTML5 Audio" using MP3 streaming. I regularly used that service already with a gstreamer enabled Firefox and it stopped working with 23. I have not checked 24 yet.
If it works in 24 it might be bug 862088.
(Reporter)

Comment 5

5 years ago
Just tested a nightly build and it also does not play. So there is still a regression somewhere since 22.
Summary: GStreamer MP3 playback fails with Aurora 23 on Google Music → GStreamer MP3 playback fails since Aurora 23 on Google Music
(Reporter)

Comment 6

5 years ago
Quite interesting fact: Firefox 23b1 works again

The error I got in Aurora 23 was (sorry, it's german):
Zeitstempel: 27.06.2013 21:10:08
Warnung: HTTP "Content-Type" "text/html" wird nicht unterstützt. Laden der Medienressource https://play.google.com/music/listen fehlgeschlagen.
Quelldatei: https://play.google.com/music/listen#/now
Zeile: 0

I'll try an Aurora 24 build soon
(Reporter)

Comment 7

5 years ago
Tried with Aurora 24 now and same error and message there.
To me it really looks like something changes when Aurora is merged to Beta which is not bound to the exact version?
(Reporter)

Comment 8

5 years ago
Anything I can help with to identify the cause?

Comment 9

5 years ago
Same problem on Windows 8:

[06:42:17.995] HTTP "Content-Type" of "text/html" is not supported. Load of media resource https://play.google.com/music/listen?u=0 failed. @ https://play.google.com/music/listen?u=0#/al//lordofthering
[06:42:19.313] TypeError: this.wi.createGainNode is not a function @ https://ssl.gstatic.com/music/fe/d52a0d1566a74f91dffa745a811ff578/listen_extended_b2b52c8b0662c265914c044480fa698eebf4c811.js:1181

Comment 10

5 years ago
I was going crazy some time ago, i thought it was just me having problem with the Google Music. I just changed it to html5 so long ago that I forgot about that option and couldn't found the problem for months.
Back to the old heavy flash version.
I'm using FF Aurora 26.0a2 (2013-09-21) on a Win8 machine.
(Reporter)

Comment 11

5 years ago
So finally the issue moved from Aurora to beta for me.
Firefox 25.0b6 does not play from Google Music any longer as MP3.
(Reporter)

Comment 12

5 years ago
ok, the reason why it fails in 25b is bug 911837 apparently. Disabling webaudio makes it work again here.
(In reply to Wolfgang Rosenauer [:wolfiR] from comment #12)
> ok, the reason why it fails in 25b is bug 911837 apparently. 

Duping then.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911837
You need to log in before you can comment on or make changes to this bug.