TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed.

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({intermittent-failure})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [defect] p=0)

Attachments

(1 attachment)

Reporter

Description

6 years ago
TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed.

https://tbpl.mozilla.org/php/getParsedLog.php?id=24275911&tree=Mozilla-Inbound

WINNT 6.2 mozilla-inbound opt test mochitest-metro-chrome on 2013-06-18 02:26:59 PDT for push ad0fa6692a65

slave: t-w864-ix-06202:30:07     INFO -  INFO | metrotestharness.exe | Launching browser...
02:30:07  WARNING -  TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed.
02:30:07  WARNING -  TEST-UNEXPECTED-FAIL | automation.py | Exited with code 2 during test run
02:30:07     INFO -  INFO | automation.py | Application ran for: 0:00:00.105000
02:30:07     INFO -  INFO | zombiecheck | Reading PID log: c:\users\cltbld~1.t-w\appdata\local\temp\tmpkgiwrtpidlog
02:30:08     INFO -  SUCCESS: The process with PID 2776 has been terminated.
02:30:08     INFO -  ERROR: The process "3160" not found.
0

Updated

6 years ago
Blocks: 880298

Updated

6 years ago
Depends on: 881950
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Blocks: metro-testing, 865451, metrov1defect&change
No longer blocks: 880298
Priority: -- → P3
Whiteboard: feature=defect c=testing u=developer p=0
Blocks: 880298
No longer blocks: metro-testing
Summary: TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed. → Defect - TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed.

Updated

6 years ago
No longer blocks: 865451
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
The slave for every one of these failures is t-w864-ix-062.  Would it be possible to verify the setup on this slave?
Flags: needinfo?(q)
Flags: needinfo?(armenzg)
Q: do you see anything weird in this screenshot of the monitors?

FYI, we can disable the machine until we figure it out; sounds good?
Flags: needinfo?(armenzg)
Sounds good to me.
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Any update here? Can we fix the bad machine or remove it from doing tests?

Comment 35

6 years ago
Graphics are fine. This machine is missing the default browser files.
Flags: needinfo?(q)

Comment 36

6 years ago
Found a bunch of testing kruft on 062. I updated it and the default browser registrations look right now. Is there an easy way to confirm ?
Flags: needinfo?
I think you could re-run the failing test on the machine, but it's easiest just to wait a few days and if doesn't come back we can close it out.
Flags: needinfo?
No longer blocks: metrov2defect&change
Summary: Defect - TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed. → TEST-UNEXPECTED-FAIL | metrotestharness.exe | GetDefaultBrowserAppModelID failed.
Whiteboard: feature=defect c=testing u=developer p=0 → [defect] p=0
Priority: P3 → --
OS: Windows 8 Metro → Windows 8.1
Inactive; closing (see bug 1180138).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.