Issues starting Web RTC on Ubuntu 13.04 x86

RESOLVED INVALID

Status

()

Core
WebRTC
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: MihaiMorar, Unassigned)

Tracking

({reproducible})

Trunk
x86
Linux
reproducible
Points:
---

Firefox Tracking Flags

(firefox22 affected)

Details

(Reporter)

Description

4 years ago
This was happening while testing FF 22b5.

STR:
1. Open a new profile and go to: 
   http://freshtilledsoil.com/the-future-of-web/webrtc-video/
2. Choose a name for your conference room and press Enter.
2. When the pop-up is displayed, choose Share Selected Devices.
3. Repeat Step 1,2 and 3 on other 2-3 machines and join same conference.

Ecpected results:
Video and audio must work as expected, without any hang, delay or interruptions.

Actual results:
Not working at all, no video is displayed while being in a conference on 2, 3 or 4 different machines on same or different networks.(Linux 13.04 x86)
(Reporter)

Updated

4 years ago
status-firefox22: --- → affected
Keywords: reproducible
(Reporter)

Comment 1

4 years ago
(In reply to Mihai Morar, QA [:MarioMi] from comment #0)

> 2. When the pop-up is displayed, choose Share Selected Devices.
This one is step 3.
> 3. Repeat Step 1,2 and 3 on other 2-3 machines and join same conference.
This one is step 4.

Sorry for the mistake done.
Summary: Web RTC is not working at all on Ubuntu 13.04 x86 → Issues starting Web RTC on Ubuntu 13.04 x86
Just to eliminate variables, have you narrowed it down to this web app and this operating system? E.g.

- Are you able to connect with https://apprtc.appspot.com on the same system?
- Does http://freshtilledsoil.com/the-future-of-web/webrtc-video/ work for you on
  another OS on your network?
- Does it work in Nightly?

Also if you could attach any output you get (web console, error console) that would help.

FWIW, I'm able to connect fine with Nightly from a few days ago on Windows <-> Mac. I get misc warnings and one error in the Web console that don't seem to affect things, like:

  Error: useless setTimeout call (missing quotes around argument?) @
  http://freshtilledsoil.com/the-future-of-web/webrtc-video/js/freshTilledSoil-webRTC-5.0.js:243

Just making sure we're not debugging their app here.
I can reproduce on an Ubuntu 12 machine doing a call between two machines. Logs say:

[14:01:25.868] Expected media feature name but found '-moz-transform-3d'. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:25.868] Expected media feature name but found '-o-transform-3d'. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:25.868] Expected media feature name but found '-ms-transform-3d'. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:25.868] Expected media feature name but found '-khtml-transform-3d'. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:25.868] Expected media feature name but found 'modernizr'. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:26.535] Unknown property 'box-sizing'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/
[14:01:27.041] Use of attributes' specified attribute is deprecated. It always returns true. @ http://platform.linkedin.com/js/nonSecureAnonymousFramework?v=0.0.2000-RC1.28251-1405&:1706
[14:01:27.041] Use of attributes' nodeValue attribute is deprecated. Use value instead. @ http://platform.linkedin.com/js/nonSecureAnonymousFramework?v=0.0.2000-RC1.28251-1405&:1707
[14:01:27.058] Unknown property '-moz-border-radius'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:27.058] Unknown property '-moz-border-radius-topright'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:27.058] Unknown property '-moz-border-radius-bottomright'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:27.066] Unknown property 'background-position-y'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:1
[14:01:27.107] Unknown property 'borderStyle'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/
[14:01:27.526] "FB.getLoginStatus() called before calling FB.init()."
[14:01:28.541] Unknown property '-moz-border-radius'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:7
[14:01:28.542] Error in parsing value for 'top'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:9
[14:01:28.542] Error in parsing value for 'right'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:9
[14:01:28.542] Error in parsing value for 'filter'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:30
[14:01:28.542] Error in parsing value for 'background'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:51
[14:01:28.543] Error in parsing value for 'background'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:58
[14:01:28.543] Unknown property 'zoom'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:76
[14:01:28.543] Error in parsing value for 'top'.  Declaration dropped. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:84
[14:01:28.544] Expected declaration but found '*'.  Skipped to next declaration. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/:92
[14:01:29.407] Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/
[14:01:30.741] "obtaining local media stream"
[14:01:31.401] "showing video conference"
[14:01:31.417] [object Object]
[14:01:35.121] "Got local media stream"
[14:01:35.122] "waiting for local video..."
[14:01:35.223] "local video streaming..."
[14:01:35.224] "Connecting to signaling socket..."
[14:01:35.225] undefined
--
[14:01:55.227] Firefox can't establish a connection to the server at ws://209.20.89.197:1337/?room=undefinedtest&r=undefined. @ http://freshtilledsoil.com/the-future-of-web/webrtc-video/js/freshTilledSoil-webRTC-5.0.js:701
--
[14:02:04.038] [object Object]
--
[14:02:13.872] GET http://ping.chartbeat.net/ping?h=freshtilledsoil.com&p=%2Fthe-future-of-web%2Fwebrtc-video%2F&u=ddkcyb58p4w9inv1&d=freshtilledsoil.com&g=42325&n=1&f=1&c=0.75&x=0&y=705&w=705&j=30&R=0&W=1&I=0&E=29&e=13&b=3513&t=icjnf335xec0oklg&V=12&_ [HTTP/1.1 200 OK 741ms]
--
[14:02:28.861] GET http://ping.chartbeat.net/ping?h=freshtilledsoil.com&p=%2Fthe-future-of-web%2Fwebrtc-video%2F&u=ddkcyb58p4w9inv1&d=freshtilledsoil.com&g=42325&n=1&f=1&c=1&x=0&y=705&w=705&j=45&R=0&W=0&I=1&E=29&e=0&b=3513&t=icjnf335xec0oklg&V=12&_ [HTTP/1.1 200 OK 386ms]
--
[14:02:43.858] GET http://ping.chartbeat.net/ping?h=freshtilledsoil.com&p=%2Fthe-future-of-web%2Fwebrtc-video%2F&u=ddkcyb58p4w9inv1&d=freshtilledsoil.com&g=42325&n=1&f=1&c=1.25&x=0&y=705&w=705&j=30&R=1&W=0&I=0&E=36&e=7&b=3513&t=icjnf335xec0oklg&V=12&_ [HTTP/1.1 200 OK 169ms]
This looks like a tech evangelism bug. There's an undefined object being sent into creation of a WebSocket object, which is causing the error. Not WebRTC related. I don't think we need to track this TE bug explicitly in bugzilla, so I'm closing this out.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.