If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[stage] New account creation skips the create profile workflow.

VERIFIED FIXED in 2013-06-27

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mbrandt, Assigned: sancus)

Tracking

other
2013-06-27

Details

(Whiteboard: [kb=1015641] [stage][regression])

(Reporter)

Description

4 years ago
When a new user creates an account, the registration process skips the profile creation steps.

This results in a home page for that user that does not have a nav bar.

Steps to reproduce:
1. create a new account on mozillians.allizom.org
2. once through the BID workflow your user will be logged in
3. note that the profile creation (username, avatar upload, etc) workflow was skipped
(Assignee)

Comment 1

4 years ago
I can't reproduce this locally at all but it's clearly easily reproduceable on stage, so I'm not exactly sure what's up...also my attempt to push stage to make it up to date with master so that we can fix it was blocked by Bug 884684 so this will have to wait until tomorrow...
Neither can I verify locally but only on stage. I talked with phrawzty to check the settings.py is correct (In case something similar to the issue 'Italian' language happened) and it is.

So we have this middle-ware in place, called 'RegistationMiddleware' which supposedly doesn't let you visit any page without completing registration. So this is really strange.

I'll investigate further.

Comment 3

4 years ago
Commits pushed to master at https://github.com/mozilla/mozillians

https://github.com/mozilla/mozillians/commit/33b0b7c0c3b6f92a02ff6573f8cc7e18d9c003fe
[fix bug 884479] Remove settings.MEDIA_URL from RegisterMiddleware when Debug = False

https://github.com/mozilla/mozillians/commit/414c88b554cca2742a8ddc65638f5ea439e70352
Merge pull request #523 from Sancus/fixmiddleware

[fix bug 884479] Remove settings.MEDIA_URL from RegisterMiddleware when ...

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Assignee: nobody → sancus
(Assignee)

Updated

4 years ago
Whiteboard: [stage][regression] → [kb=1015641] [stage][regression]

Comment 4

4 years ago
This is verified and fixed. Thanks!
Status: RESOLVED → VERIFIED
Target Milestone: --- → 2013-06-27
You need to log in before you can comment on or make changes to this bug.