If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't see scroll bars on pages with black background

RESOLVED WONTFIX

Status

()

Core
Widget: Cocoa
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: \, Unassigned)

Tracking

({regression})

24 Branch
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lion-scrollbars-], URL)

When visiting a page [1] with a black background in FF24, the native scroll bars are not visible!  The example is black about 80% of the way down the page.

Comment 1

4 years ago
WFM with FF24 on Win 7. I think it's specific to Mac OSX 10.7 due to bug 636564.

1) Are you using Lion?

2) Could you confirm the bug is not present with Firefox 21?
Component: General → Widget: Cocoa
Flags: needinfo?(ndesaulniers)
Keywords: regression
Product: Firefox → Core
(This comment assumes that this bug was written against the new overlay scrollbars from bug 636564)

Some work went into detecting the background color to choose the right color of the scrollbars (brigther on dark background) in bug 865806. Since this is a one-time check, the scrollbars don't change color once the page is scrolled down to the dark part.

We are currently aiming for parity with Safari, which I've confirmed has the same problem. However, we may consider an enhancement that would change the scrollbar color in this situations.
Depends on: 865806
Whiteboard: [lion-scrollbars-]
I don't think that's a good idea.  What would we do when the black background is partly under the scrollbar?  Also, having the scrollbar change its color seems really bad.

There's just no way we can handle every possible case out there.
@Loic,
1. I am using Mac OSX 10.8.4 Mountain Lion.
2. I confirm that this bug is not present in Firefox 21.0
Flags: needinfo?(ndesaulniers)
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #3)
> There's just no way we can handle every possible case out there.

Agreed, closing this for now based on this. Nick, please reopen if you see a significant difference between what our scrollbars currently do and what other browsers do. Thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.