Deploy production Marketplace instance for testing against Persona stage

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: jedp, Assigned: jason)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

In order to assure that Marketplace sign-in is not broken in any way by Persona production deployments, which occur every two weeks, we would like to have two Marketplace servers stood up and pointed at the Persona staging deployment: One production Marketplace, the other Marketplace stage.

These don't need to be particularly fast or fancy.  Whatever the minimum hardware requirements are will almost certainly be fine.
back story: we had a login outage yesterday in prod caused by a Persona change that revealed a bug in Marketplace's code. The bug was silently ignored until the new Persona release.

The new servers will let Persona team test our integration before it hits prod. I think these servers could be set up to auto-update once a day or whatever like stage.
And going forward, we would want to be able to push any new Marketplace staging and production code directly to the testing servers as well.

Comment 3

5 years ago
Do you want to meet sometime next week to discuss requirements?

Comment 4

5 years ago
oremj - Awesome! Yes, we'd like to meet ASAP as we ship every two weeks and our QA are happy to test this new environment before green lighting a production push.

Updated

5 years ago
Whiteboard: qa+
I've updated the title - Marketplace's production release schedule is more frequent than Perona's (currently once per week vs Persona at once every two weeks), so we should be well covered by a single instance: Marketplace prod pointing to Persona stage
Summary: Deploy stage and production Marketplace servers for testing against Persona stage → Deploy production Marketplace instance for testing against Persona stage

Comment 6

5 years ago
Current Plan:
oremj/jason to create Identity-stage.marketplace.allizom.org

This stage is a copy of latest Marketplace production code pointed at Persona stage (https://login.anosrep.org)

Work will start roughly after July 15th.

Meeting notes: https://etherpad.mozilla.org/persona-marketplace-stage-env

oremj has volunteered a manual stage flip during our final QA pass for Persona production releases, as a temporary workaround.
FYI, if you also want to connect to payments you'll need a webpay instance configured for persona stage in addition to Marketplace
Whiteboard: qa+ → [qa+]

Comment 8

5 years ago
Start date has slipped to 7/25.
(Assignee)

Updated

5 years ago
Assignee: server-ops-amo → jthomas
Hi :jason, is there anything I can do to help get this in place? Thanks.
(Assignee)

Updated

5 years ago
Depends on: 902229
(Assignee)

Comment 10

5 years ago
Just an update, I have been working on this instance this week and https://identity-stage-marketplace.allizom.org/ is almost ready.
I see that https://identity-stage-marketplace.allizom.org is down (Noticed it on Wednesday, but didn't update here). It was up on Tuesday.
(Assignee)

Comment 12

5 years ago
Should be fixed now. The auto update failed and I had to redeploy to the environment again. Let me know if you have any issues.
Thanks. Looks like it's working for me.
(Assignee)

Comment 14

5 years ago
https://identity-stage-marketplace.allizom.org/ has been configured with a copy of the landfill database and assets. The environment will update to the latest tag for zamboni, webpay, and fireplace every night. Let me know if there are any issues.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Great work, thanks again!
Works for me. Marking as Verified since we have the [qa+] up there in the Whiteboard ;-)
Status: RESOLVED → VERIFIED
Component: Server Operations: AMO Operations → Operations: Marketplace
Product: mozilla.org → Mozilla Services
You need to log in before you can comment on or make changes to this bug.