New build system: Partial builds from a leaf in the build tree do not update makefiles as they used to

RESOLVED INVALID

Status

Firefox Build System
General
RESOLVED INVALID
5 years ago
4 months ago

People

(Reporter: Steve Williams, Unassigned)

Tracking

22 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193848

Steps to reproduce:

Modified a makefile in a subdirectory in my source tree.
Ran make from the equivalent subdirectory in my build tree & one level higher.



Actual results:

Noticed the modified makefile was not updating, as it used to.
Was advised that I now have to always build from the root of my build tree.


Expected results:

The modified makefile should have updated, as used to be the case & the build system should have attempted to complete in the sub-tree I initiated it from. 

I understand that partial makes do not always complete correctly due to missed binding steps etc, but when you're just developing that doesn't always matter - you just want a fast modify/test cycle. You can run a full build when you have something that builds without errors. That's what we used to be able to do. The build system is therefore not as efficient as it used to be. If this is transitional, not a problem. If it's a design decision, please look at it again.
(Reporter)

Comment 1

5 years ago
weird - seems to work as expected now when I run from a leaf directory.

will run a couple more tests when I get a minute.

Comment 2

5 years ago
Can you confirm you are running the tip of mozilla-central? There was a lot of work in bug 874543, bug 874078, and bug 848530, and bug 879809 that touched all this code and AFAIK tip of m-c works just fine.

Updated

5 years ago
Flags: needinfo?(steve)
(Reporter)

Comment 3

3 years ago
sorry - this is old & resolved afaik. please close.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(steve)
Resolution: --- → INVALID

Updated

4 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.