Closed Bug 884728 Opened 9 years ago Closed 9 years ago

[Facebook] Linking feature is broken deleting all local information for a contact

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+, b2g18? verified, b2g-v1.1hd fixed)

RESOLVED FIXED
blocking-b2g leo+
Tracking Status
b2g18 ? verified
b2g-v1.1hd --- fixed

People

(Reporter: crdlc, Assigned: crdlc)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:

1) Go to contacts app
2) Create a new one with given name "Manolo", family name "Flores" and work in "Balay"
3) Click on "link to"
4) Choose a friend, for example, "Pedro" "Vaquero" working in "Ufesa"

Expected results:

My contact should be Manolo Flores working on Balay but enriched with the rest of info of Pedro (telephone or address)

Current result:

My local contact is Pedro Vaquero working for Ufesa and the Facebook mini-logo doesn't appear on the list. After rebooting, the contacts list seems ok, but contact detail and form are wrong.

----

The bug is iterating a device contact provided by the API in this point:

https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/contacts/js/fb/fb_contact.js#L290

Right now:

console.log(devContact.givenName); --> "Manolo" 
console.log(Object.keys(devContact).length); --> 1 only "id" prop is available iterating

At least this bug is reproducible on v1-train and master.
Hi Gregor, 

   I hope that you can help us, is there any change on the implementation? Should we iterate in a different way? 

Thanks a lot
Flags: needinfo?(anygregor)
blocking-b2g: --- → leo?
(In reply to Cristian Rodriguez de la Cruz (:crdlc) from comment #1)
> Hi Gregor, 
> 
>    I hope that you can help us, is there any change on the implementation?
> Should we iterate in a different way? 
> 
> Thanks a lot

I tried to reproduce it with a current trunk build today but when I click on link and I access facebook I only get the Error: "The parameter app_id is requried"
Flags: needinfo?(anygregor)
I talked to mrbkap about the security wrappers we have in place here but this should all work with your link you posted. You might want to enable debugging in the contacts api to get further debug output.
I detected the problem, thanks Gregor!
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Patch v1
Attachment #765237 - Flags: review?(jmcf)
Blocks: 885243
tracking-b2g18: --- → ?
Comment on attachment 765237 [details]
Patch v1

works perfectly

thanks!
Attachment #765237 - Flags: review?(jmcf) → review+
https://github.com/mozilla-b2g/gaia/commit/427e0100826c677cee1341c4d83793321f16bb5f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Adding qawanted to help check if this happens on 1.0.1 or if this is a regression or part of a new feature?
Keywords: qawanted
Regarding 1.0.1, Using ZTE device and:

Gecko 
Gaia   6d1008a5f7b4509dd84eca47d036bc65c462714a
BuildID 20130528231041
Version 18.0

I don't see this issue. If I understand the initial comment, he is linking a contact that has a different name and contact information than the Facebook contact name.

STR:
1. Enable Facebook in Contacts
2. Create a contact with a different name and contact information.
3. Link that contact to an existing Facebook contact that does not have the same name.
4. Confirm all contact information is preserved.
Keywords: qawanted
I can reproduce it on master and v1-train as I said
blocking-b2g: leo? → leo+
Keywords: regression
Duplicate of this bug: 885243
Uplifted 427e0100826c677cee1341c4d83793321f16bb5f to:
v1-train: 84b83b20a2f0c66798c60438e12655c458937754
v1.1.0hd: 84b83b20a2f0c66798c60438e12655c458937754
Varified,fixed on LEO Mozilla RIL
Environmental Variables
Build ID: 20130716070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/629020cf576b
Gaia: fb9362d34260771d4a00b9a0e10a6bbad397bd3b
Platform Version: 18.1
RIL Version: 01.01.00.019.158 

Varified that My contact is Manolo Flores working on Balay but enriched with the rest of info of the other contact to whom it is linked.
You need to log in before you can comment on or make changes to this bug.