trunk & M092 crash [@ nsRenderingContextGTK::GetWidth]

VERIFIED DUPLICATE of bug 88486

Status

()

Core
Networking: HTTP
VERIFIED DUPLICATE of bug 88486
17 years ago
17 years ago

People

(Reporter: Jan Carpenter, Assigned: neeti)

Tracking

({crash, topcrash})

Trunk
x86
Linux
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

17 years ago
This bug is a topcrasher for trunk & M092.

Here are some URLs & Comments that might help repro this crash:

M092:
(32275377)
URL: http://www.theinquirer.net/21060111.htm
(32275377)
Comments: Mozilla crashed on opening of the page. I was reviewing mozilla bugs
81359 and 85059. 

trunk:
 (32246534)	URL: http://home.netscape.com
(32246534)
Comments: When you add "User Defined" charset by using View | Character Coding |
CustomizeThen load page http://home.netscape.comChange the charset to "User
Defined"You will the crash
     (32244937)	URL: http://www.theinquirer.net/10060101.htm
(32244937)
Comments: Crash when reload this page

Here is a recent stack trace from build 2001062706:

Incident ID 32275439
nsRenderingContextGTK::GetWidth()
nsTextFrame::ComputeWordFragmentWidth()
nsTextFrame::ComputeTotalWordWidth()
nsTextFrame::MeasureText()
nsTextFrame::Reflow()
nsLineLayout::ReflowFrame()
nsBlockFrame::ReflowInlineFrame()
nsBlockFrame::DoReflowInlineFrames()
nsBlockFrame::DoReflowInlineFramesAuto()
nsBlockFrame::ReflowInlineFrames()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsBlockReflowContext::DoReflowBlock()
nsBlockReflowContext::ReflowBlock()
nsBlockFrame::ReflowBlockFrame()
nsBlockFrame::ReflowLine()
nsBlockFrame::ReflowDirtyLines()
nsBlockFrame::Reflow()
nsContainerFrame::ReflowChild()
CanvasFrame::Reflow()
nsBoxToBlockAdaptor::Reflow()
nsBoxToBlockAdaptor::DoLayout()
nsBox::Layout()
nsScrollBoxFrame::DoLayout()
nsBox::Layout()
nsContainerBox::LayoutChildAt()
nsGfxScrollFrameInner::LayoutBox()
nsGfxScrollFrameInner::Layout()
nsGfxScrollFrame::DoLayout()
nsBox::Layout()
nsBoxFrame::Reflow()
nsGfxScrollFrame::Reflow()
nsContainerFrame::ReflowChild()
ViewportFrame::Reflow()
nsHTMLReflowCommand::Dispatch()
PresShell::ProcessReflowCommand()
PresShell::ProcessReflowCommands()
HandlePLEvent()
PL_HandleEvent()
PL_ProcessEventsBeforeID()
processQueue()
nsVoidArray::EnumerateForwards()
nsAppShell::ProcessBeforeID()
handle_gdk_event()
libgdk-1.2.so.0 + 0x174b7 (0x403214b7)
libglib-1.2.so.0 + 0x10348 (0x40351348)
libglib-1.2.so.0 + 0x10953 (0x40351953)
libglib-1.2.so.0 + 0x10aec (0x40351aec)
libgtk-1.2.so.0 + 0x8d667 (0x40272667)
nsAppShell::Run()
nsAppShellService::Run()
main1()
main()
libc.so.6 + 0x1d2db (0x4048d2db)
(Reporter)

Comment 1

17 years ago
adding crash & topcrash to keywords
Keywords: crash, topcrash

Comment 2

17 years ago
dup of bug 86436?
if not, then i have a 100% reproducible testcase:
1. load www.mts.ru
2. crash...
Duplicate of bug 88486 via bug 88927.  And this should be fixed on the trunk now!

*** This bug has been marked as a duplicate of 88486 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verifying dup.
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsRenderingContextGTK::GetWidth]
You need to log in before you can comment on or make changes to this bug.