moazActivity doesn't give any response (no success and no error)

RESOLVED WONTFIX

Status

Firefox OS
Gaia
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: Guillaume PARIS, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 764676 [details]
Logs and Photo to try to reproduce it

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.45 Safari/537.36

Steps to reproduce:

We are using the mozActivity picker to pick an image from the gallery and use it in a third party app. We are testing this action in different devices in FFOS 1.0.1 and getting different error conditions (on unagi and ZTE device), when trying to retrieve images from gallery through picker (ok with camera and wallpaper). It also seems to be ok with latest 1.1.0 build.

Code of the picker:

 pickImage: function () {
      var _this = this;
      var activity = new MozActivity({
        name: 'pick',
        data: {
          type: ['image/jpeg', 'image/jpg']
        }
      });

      activity.onsuccess = function () {
        console.log('**init pickImage activity.onsuccess convID: ' +
          _this.conversation.get('id'));
        var contents = {
          caption: null,
          blob: this.result.blob,
          thumbSrc: null
        };

        _this.model.set('type', 'image');
        _this.model.set('contents', contents);
        _this.model.set('from', {msisdn: global.auth.get('msisdn')});
        _this.model.set('meta', new Date());
        _this.renderImage();
      };

      activity.onerror = function () {
        console.log('error picking image: ' + this.error);
        global.router.navigate('conversation/' + _this.conversation.get('id'),
        { trigger: true });
      };
    }

build identifier:  20130528185614
Git commit info: 2013-06-10 10:22:19 7bca377199e7c73480a97f3c33d3ed9...



Actual results:

Sometimes the picker returns to our app without any response (neither success nor error). Would it be possible to capture this type of action in our app to try to debug the problem or at least protect our app with a controlled error? 



Expected results:

return to our app with a success or error response
(Reporter)

Comment 1

5 years ago
Gaia branch v1.0.1
Can you please check this case in a current build (2.0 or higher). I will leave this open for the next week and after that I will close this as wont fix due to the age (adding NI to myself so i can get back to it)
Flags: needinfo?(guillaume.paris.work+owd-bug)
Flags: needinfo?(charja13)
This bug is being closed, as I stated above I would close after one week if no response so I am doing so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(guillaume.paris.work+owd-bug)
Flags: needinfo?(charja13)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.