Weird 404 SMS from an italian provider.

RESOLVED INVALID

Status

()

Core
DOM: Device Interfaces
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: baku, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
It's hard to describe this bug, and I don't have technical information about it.

I'm trying firefoxOS with an italian provider (if needed I can tell which one) and an italian phone number.
I pay a fix amount of euro per month for X gb of internet, Y number of SMSs, Z minutes of calls.

It seems that the phone sends SMSs to retrieve some information from the network, and those SMSs are paid separately. So, after a while, Firefox OS consumes all my credit. When it does, I receive weird messages saying: "You don't have enough credit to send this message". The original message is in italian. This happens 20 times or more a day and it's not related to the real messages I send.

Just to be clear: I can send SMSs and they are perfectly received. I can call and internet works - this because I paid for them at the beginning of the month. But often, randomly, I receive these SMS...

Speaking with the provider, they told me that probably my phone is asking for some kind of information to the network, using the messaging protocol (i'm not expert of this so probably I'm using wrong words). This has a cost, and this finishes my credit.

If I have to guess when these messages are receives, I'd say:

1. when I send a message. Immediately after - but my message is delivered fine.

2. when the network status changed (I'm not 100% sure about this). For instance, if I change from 3G to E, because of the coverage of the signal

3. random

I don't know if this can be useful, but the sender of these SMSs is 404 number.

No logs in adb logcat. This bug is 100 reproducible with a custom build or standard one.
A few bits from googling:

http://answers.yahoo.com/question/index?qid=20080612190304AAT02al
dial *123# for WIND SIM; call 404 for Vodafone SIM.

http://www.galtech.co.uk/pdf/gsm-vac4-plus-lite-manual.pdf
Low credit alarm, don't know if it's relevant.
Flags: needinfo?
(Reporter)

Comment 2

5 years ago
> http://answers.yahoo.com/question/index?qid=20080612190304AAT02al
> dial *123# for WIND SIM; call 404 for Vodafone SIM.

The bug here is that, let's assume is the firmware (or some component) checking if the credit is low, this should not use credit doing it... Any idea how I can debug it?
Flags: needinfo? → needinfo?(vyang)
(Reporter)

Comment 3

5 years ago
It was a weird configuration of the sim card.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Flags: needinfo?(vyang)
If you're able to build Gecko from source, you may turn on debug message by editing gecko/dom/system/gonk/ril_consts.js and set DEBUG_ALL[1] to true.  Or, please see bug 820699 for steps to enable RIL debugging messages.

[1]: https://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_consts.js#17
You need to log in before you can comment on or make changes to this bug.