Closed Bug 884774 Opened 10 years ago Closed 10 years ago

If the user attempts to purchase an application from MP Stage they will receive an error message which reads “Sorry, you are not allowed to do that”.

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: vikas.nanda, Unassigned)

References

Details

Attachments

(4 files)

Attached file log file
steps to reproduce:

1. Start the MP Stage application
2. Search for paid application.
3. Click buy
4. Sign into your account. 
5. Notice the error message "Sorry, you are not allowed to do that"

expected behavior:
The payment should complete and the user should be able to install the application. 

observed behavior:
The payment fails with the error message, "Sorry, you are not allowed to do that"
Attached image screenshot
FW version: Boot2Gecko 1.0.1.0-prerelease
MP: MP Stage
Region:Poland

Example application which I tried to purchase https://marketplace.allizom.org/app/pricepoint1-010/
This bug is also reproduced in Seville.
Attached file ezboot log for Seville
Attached file logcat for Seville
I see these verification failures in the logs:

Jun 19 08:37:44 web19.stage.addons.phx1.mozilla.com: [][] requests.packages.urllib3.connectionpool:INFO Starting new HTTPS connection (1): firefoxos.persona.org :/data/www/addons.allizom.org/venv/lib/python2.6/site-packages/requests/packages/urllib3/connectionpool.py:533
Jun 19 08:37:44 web19.stage.addons.phx1.mozilla.com: [][] django_browserid.base:WARNING BrowserID verification failure. Response: {u'status': u'failure', u'reason': u'bad signature in chain'} Audience: https://marketplace.allizom.org :/data/www/addons.allizom.org/venv/lib/python2.6/site-packages/django_browserid/base.py:153
There was a 5 minute TTL on the cname switch which explains the verification error above.

However, I don't know if these temporary verification errors are the root cause. Is the login issue still occurring?
Disregard the info above. The screenshot means you are trying to make a purchase but your email address is not whitelisted (see bug 879360). You must log in with an @intertek.com Persona address. Which Persona email where you using?
We are only whitelisting @mozilla.com and @intertek.com addresses right now. Let me know if you need a specific Persona account whitelisted.
Tested with @intertek.com and it is working.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.