The default bug view has changed. See this FAQ.

In the contacts sidebar in compose window, the column titles of the found cards list are white

RESOLVED FIXED in Thunderbird 26.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aceman, Assigned: Paenglab)

Tracking

({polish})

Trunk
Thunderbird 26.0
x86
Windows XP
polish

Thunderbird Tracking Flags

(thunderbird24 fixed, thunderbird25 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 764725 [details]
screenshot

In the contacts sidebar in compose window, the column titles of the found cards list are white.
It is caused by 3 { background-color: transparent; } style in 
chrome://messenger/skin/addressbook/abContactsPanel.css applying to these elements.

Can you check if those are intentional (e.g. so that the panel can be overlaid on different backgrounds) or just a mistake?

This was found on Win XP but please check other OSes too.
(Assignee)

Comment 1

4 years ago
Created attachment 765477 [details] [diff] [review]
patch

You are correct, this is only visible on classic Windows where the treecols are affected by such stylings. On all other systems the -moz-appearance: treeheadercell hides the custom stylings.

I've also removed unneeded rules which are already in addressbook.css and included with the @import on top of abContactsPanel.css.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #765477 - Flags: ui-review?(mconley)
Attachment #765477 - Flags: review?(mconley)
(Assignee)

Comment 2

4 years ago
Created attachment 774142 [details] [diff] [review]
patch unbitrotted

Unbitrotted patch after landing of bug 865670.
Attachment #765477 - Attachment is obsolete: true
Attachment #765477 - Flags: ui-review?(mconley)
Attachment #765477 - Flags: review?(mconley)
Attachment #774142 - Flags: ui-review?(mconley)
Attachment #774142 - Flags: review?(mconley)
Comment on attachment 774142 [details] [diff] [review]
patch unbitrotted

Review of attachment 774142 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the delay! Thanks Richard!
Attachment #774142 - Flags: ui-review?(mconley)
Attachment #774142 - Flags: ui-review+
Attachment #774142 - Flags: review?(mconley)
Attachment #774142 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

4 years ago
Comment on attachment 774142 [details] [diff] [review]
patch unbitrotted

[Approval Request Comment]
This is only a visual bug and could help TB 24ESR to look better but this was a bug which was in since a long time without any user reaction, so it makes nothing when it can't land on ESR.
Attachment #774142 - Flags: approval-comm-beta?
Attachment #774142 - Flags: approval-comm-aurora?
Attachment #774142 - Flags: approval-comm-beta?
Attachment #774142 - Flags: approval-comm-beta+
Attachment #774142 - Flags: approval-comm-aurora?
Attachment #774142 - Flags: approval-comm-aurora+
https://hg.mozilla.org/comm-central/rev/3ad2c3980fc3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 26.0
https://hg.mozilla.org/releases/comm-aurora/rev/6013a4dd10d8
https://hg.mozilla.org/releases/comm-beta/rev/27e04dbca776
status-thunderbird24: --- → fixed
status-thunderbird25: --- → fixed
You need to log in before you can comment on or make changes to this bug.