mobile.reuters.com sends a low-fi mobile version to Firefox OS

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: efrat, Assigned: karlcow, Mentored)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff][sitewait] [country-all] , URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce:

Browsed to "http://mobile.reuters.com/" from Gaia browser

Tested on Firefox OS simulator
OS version 1.1.0.0-prerelease
Build Identifier 20130522133646

User Agent String is:
Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36


Actual results:

In the simulator - The site uploads as a desktop site and not mobile adjusted

On a device - The site uploads as a desktop site and not mobile adjusted (same)



Expected results:

The web page should have been displayed
Confirmed. But I don't think they serve us their desktop site. It looks more like a very skinny and limited mobile site instead.

There is also a scrolling issue but I don't know if that is Reuters or related to hiding the location bar in the Gaia browser.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Just a quick note that I do get a proper and different mobile site on iOS/Safari or Android/Chrome. What they serve to Firefox OS is certainly not their best mobile experience.
To quote the start of the source code:

<!--[if !IE]> App Server /S264630NJ2XSF58/ <![endif]-->
<!--[if !IE]> Device Type /xhtml/ <![endif]-->
<!--[if !IE]> User Agent /Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0/ <![endif]-->

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" 
          "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">

We would like to be recognised as Device Type "smart"
(and no, I don't understand why those are conditional comments either...)
Whiteboard: [serversniff][contactready]
(Assignee)

Comment 5

5 years ago
* Opera Mobile and Firefox Android receives the same version than iOS Safari
* Firefox OS receives the lowfi mobile version.
Assignee: nobody → kdubost
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [serversniff][contactready] → [serversniff][contactready] [country-all]
(Assignee)

Updated

5 years ago
Depends on: 804716
(Assignee)

Updated

5 years ago
Summary: mobile.reuters.com doesn't display correctly in Gaia browser → mobile.reuters.com sends a low-fi mobile version to Firefox OS
(Assignee)

Comment 6

5 years ago
pinged them about it.
Whiteboard: [serversniff][contactready] [country-all] → [serversniff][sitewait] [country-all]
(Assignee)

Updated

5 years ago
No longer depends on: 804716
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

4 years ago
contacttwitter
The current status right now.

When entering http://reuters.com/ on:

* Firefox OS 1.2        -> desktop content
* Firefox Android 30    -> redirected to http://mobile.reuters.com/ with nice UI
* Opera Android Ch20    -> redirected to http://mobile.reuters.com/ with nice UI
* UCBrowser Android 9.7 -> redirected to http://mobile.reuters.com/ with nice UI

When entering http://mobile.reuters.com/ on 
* Firefox OS 1.2        -> low-fi mobile content

I sent a reminder again to the address I had but they seem to ignore.
Let's see if we can find a human being. :)
http://twitter.com/MozWebCompat/status/451924544333180928
Whiteboard: [serversniff][sitewait] [country-all] → [serversniff][sitewait] [country-all] [mentor=kdubost]
(Assignee)

Updated

4 years ago
Depends on: 804716

Updated

4 years ago
Mentor: kdubost
Whiteboard: [serversniff][sitewait] [country-all] [mentor=kdubost] → [serversniff][sitewait] [country-all]
(Assignee)

Comment 8

4 years ago
contacttwitter
Asked for a status :/
http://twitter.com/MozWebCompat/status/534640775384952833
Created attachment 8563804 [details]
Screenshot from Flame smartphone
(Assignee)

Comment 10

3 years ago
The same version seems to be sent to Firefox Android and Firefox OS.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.