Suggestion: Use full area of high resolution icon for displaying icons in home screen instead of wrapping icon in a button

RESOLVED FIXED in Firefox 25

Status

()

Firefox for Android
Awesomescreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sole, Assigned: wesj)

Tracking

Trunk
Firefox 25
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This will make shortcuts blend nicely with the rest of icons, and make better use of the provided high resolution icons where present.

Current favicon-in-a-button style could be still used when the website doesn't provide a high resolution icon.

Comment 1

5 years ago
Do you have a screenshot of how it current looks?
(Reporter)

Comment 2

5 years ago
It was for another bug, but here's more or less how they look currently in different versions: https://bug884848.bugzilla.mozilla.org/attachment.cgi?id=764781

Comment 3

5 years ago
Hmm not sure what the issue is.  I created a transparent .png for the homescreen/launcher icon.  It seems to be adding in a background behind the icon?  

Here's some documentation:
http://developer.android.com/design/style/iconography.html#launcher
(Reporter)

Comment 4

5 years ago
Yes, it currently adds a background i.e. puts the provided icon in a button. My suggestion is to stop doing that, and use the app-provided icon without further modifications.
(Assignee)

Comment 5

5 years ago
Created attachment 767841 [details] [diff] [review]
Patch

You ok with this mfinkle? I thought at one point we wanted to emphasize these are "bookmarks" and not "apps", but I could be remembering wrong.

We should use apple-touch-icon as well, but that will require more work updating our favicon db to handle storing multiple icons (or at least the urls for multiple icons) for a single site.
Attachment #767841 - Flags: review?(mark.finkle)
Comment on attachment 767841 [details] [diff] [review]
Patch

The patch itself looks fine, but I think we need get Ian to buy into this idea. Some screenshots showing the difference might be useful.
Attachment #767841 - Flags: review?(mark.finkle) → review+
Flags: needinfo?(ibarlow)
(In reply to Wesley Johnston (:wesj) from comment #5)
> Created attachment 767841 [details] [diff] [review]
> Patch
> 
> You ok with this mfinkle? I thought at one point we wanted to emphasize
> these are "bookmarks" and not "apps", but I could be remembering wrong.
> 

I remember that too, but I think I'm less concerned about that than I once was. If we can get bigger and better looking icons, we should.

Some screenshots would be nice, though.
Flags: needinfo?(ibarlow)

Updated

5 years ago
Assignee: nobody → wjohnston
OS: Mac OS X → Android
Hardware: x86 → ARM
https://hg.mozilla.org/mozilla-central/rev/9b97d49ba331
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
You need to log in before you can comment on or make changes to this bug.