[webvtt] The loading of cue data is timing out in tests on android

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: reyre, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Blocks: 833386, 884879, 882131
(Reporter)

Updated

5 years ago
Blocks: 883173
(Reporter)

Comment 1

5 years ago
So the "loadedmetadata" event doesn't seem to be being called in the way we have our test's currently set up.

https://tbpl.mozilla.org/?tree=Try&rev=6e228a4c49f8 does not work (relying on loadedmetadata event to tell us when cue's are loaded) but https://tbpl.mozilla.org/?tree=Try&rev=6c0dd7bed40e&pusher=rick.eyre@hotmail.com does work (relying on HTMLTrackElement ready state to tell us).
No longer blocks: 884879
(Reporter)

Comment 2

5 years ago
Created attachment 767732 [details]
Test case for not loading metadata
(Reporter)

Comment 3

5 years ago
Is "loadedmetadata" not supposed to be called on mobile Chris? I've checked on Webkit and it seems to behave the same way as Firefox for Android.
Flags: needinfo?(cpearce)
By default, on mobile we set the "preload" attribute on media elements to "none". This is to prevent excessive data charges on 3G plans etc.

Try adding "preload" or "preload=auto" to your media elements.
Flags: needinfo?(cpearce)
(Reporter)

Comment 5

5 years ago
This works perfectly. Thanks Chris.

Marking as invalid as we understand the problem and it's not a bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.