Mozilla renders unknown tags as a form of whitespace

RESOLVED DUPLICATE of bug 66468

Status

()

RESOLVED DUPLICATE of bug 66468
17 years ago
17 years ago

People

(Reporter: q4uad, Assigned: clayton)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

As can be seen in the attached test page (I apologize for the banner ad) ,
Mozilla renders invalid tags. I have tried this in both "quirk" and strict mode
and it occurs in both methods.

I hope this is fixed in the next version. I love how far Mozilla has come.

Also, requiring someone to register for a user is a bit onerous for just
reporting a single bug.

Scott.

Reproducible: Always
Steps to Reproduce:
1. Load http://dsn.itgo.com/vo/test.html
2. Watch it and love it.

Actual Results:  Rendered invalid HTML as whitespace.

Expected Results:  The browser should have ignored the tag completely.

<html>
<body>
  <table>
    <tr>
      <td>
        Not indented.
      </td>
    </tr>
  </table>
  <table>
    <tr>
      <badtag>
      <td>
        Not indented?
      </td>
    </tr>
  </table>
</body>
</html>

Comment 1

17 years ago
Confirming on 2001071304-trunk (w32), but this looks like a dup of bug 66468 to me.
We're probably putting the tag in the content model and then handling it as
unknown content within a table.

*** This bug has been marked as a duplicate of 66468 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

17 years ago
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.