JPEGs are saved as text files

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: John Roblin, Unassigned)

Tracking

21 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Saving JPEG files by right clicking on them and selecting Save Picture.
Saving web pages with the File -> Save Page As function.
Further unique behaviour when saving pictures from Twitter.


Actual results:

When saving JPEGs Firefox lists Text Document (.txt) in the "Save as type:" combo-box. Usually the file is saved correctly but sometimes the picture is actually saved as a text file.
If a file is saved from Twitter the extension ".jpg large" is appended (which is correct behaviour) in the save dialogue but in actuality the file is saved as ".jpg large.jpg%20large".
When a web page is saved all the JPEG files are saved as .txt files.


Expected results:

Text Document should not be shown. JPEGs should always save as JPEGs / JPGs.
If you remove the "large" the file saves fine. If you remove the "jpg large" the file does not save correctly (it used to in previous versions.)
When saving a web page all the files should save correctly. I now have to change the extensions of hundreds of files with the help of specialised software.
(Reporter)

Comment 1

4 years ago
CORRECTION- "Save Picture" should read as "Save Image As..."

Comment 2

4 years ago
Does this happen with *any* image files on the internet, or only for those from Twitter?
Could you provide a link to a testcase?
Flags: needinfo?(john.roblin)
(Reporter)

Comment 3

4 years ago
Sorry, I thought I'd explained this clearly enough. To restate- if you save any JPEG from anywhere it shows "Save as type: Text Document". Now most of the time the picture is saved correctly but at an odd few times it is indeed saved as a text file. It might have something to do with the coding of the particular site but I can't give specific enough examples other than Twitter (because its behaviour is different from other sites) as I haven't been keeping thorough enough records to distinguish this behaviour between individual sites.
Concerning Twitter exclusively- The whole ".jpg large" thing has been normal behaviour for as long as I can remember. On further examination (looking at older files I've saved in the past) Firefox would actually save the file as "[NAME OF FILE].jpg large.jpg", which is fine by me (I can live with the extra large bit) but now instead saves files as described earlier (e.g. "[NAME OF FILE].jpg large.jpg%20large" which is useless as ".jpg%20large" can't be opened. The speech marks just indicate where the file naming begins and ends and is not actually part of the file just to be clear. If you want to recreate this for yourself, follow someone on Twitter who shares photos via twimg (Twitter's own image sharing service, not Instagram, Twitpic etc.) Here is one from the one and only Jeff Gerstmann as an example- https://twitter.com/jeffgerstmann/status/347551955821944835/photo/1 If you right click on the picture and select View Image you can see the twimg URL.
Saving any website from anywhere results in all JPEGs on that site being saved as text files in the site's folder. PNGs, GIFs, etc. are not affected.
I'm 90% sure this started happening after the update to v21 although I suppose there is still a chance one of my add-ons is causing this problem as a result of the upgrade. I waited for a couple of weeks before reporting this bug as I assumed it would have been discovered quickly as people save pictures all the time but then I realised that you have two other builds out there to download at any time so I was surprised this bug slipped through.
Flags: needinfo?(john.roblin)

Comment 4

4 years ago
Could you test with a new profile, please:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Maybe bad prefs about file handling.
Flags: needinfo?(john.roblin)
(Reporter)

Comment 5

4 years ago
***RESOLVED***

Yeah, that was it. A new profile was fine and after searching for "bad prefs about file handling" I was reminded about mimeTypes.rdf; quitted, changed its extension to ".old", launched again and JPEGs seem fine now. I'd actually had to do this again previously not two weeks ago because mailto: had stopped working; again, quite out of the blue. Hopefully now this isn't a reoccurring problem due to a faulty add-on or something.

Anyway, many thanks for pointing me in the right direction. Generating a new mimeTypes.rdf doesn't mean I lose any personal settings does it? The file is a lot smaller now than it was previously.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(john.roblin)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.