[PP][BLOCKER] nsIWidget::CaptureMouse not implemented on Mac

VERIFIED FIXED in M10

Status

()

Core
XUL
P3
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: dcone (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] waiting for feedback on how to verify)

(Reporter)

Description

19 years ago
System mouse capture not implemented for Mac. This is needed to fully implement
frame-based combo boxes.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Blocks: 11587

Updated

19 years ago
Severity: normal → blocker

Comment 1

19 years ago
We need this in M10, marking as blocker severity

Updated

19 years ago
Blocks: 11346

Comment 2

19 years ago
Not a M9 blocker...setting to M10.
Target Milestone: M10

Comment 3

19 years ago
Don, what is the status of this?  It is blocking us, and we need it real soon.

Comment 4

19 years ago
cc'ing RickG to find out why there has been no activity on this bug.
(Assignee)

Comment 5

19 years ago
The problem is that there is a need to capture a mousedown event when the user
clicks outside the applications space and to not switch the
other application or desktop in as the current application.
According to Inside Mac (old version), all the current application will get is a
suspend event if the user clicks outside the application space.
Is that absolutly true or is there a way around this under System 8.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
We are using rollup events for this task, so this is fixed... indirectly using
the new rollup events.

Comment 7

19 years ago
Sorry for spam, re-assigning phillip's QA contact XPToolkit/XPWidget bugs to
claudius due to restructure

Updated

19 years ago
Whiteboard: [PDT+]

Comment 8

19 years ago
Putting on [PDT]+ radar.

Updated

19 years ago
Whiteboard: [PDT+] → [PDT+] waiting for feedback on how to verify

Comment 9

19 years ago
If someone could kindly suggest steps to reproduce/test this I would glady do so. Otherwise,
if the owner/reporter could mark it verified that would be cool too.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
tick-tock, time waits for no man, or bug, especially not after a month

marking VERIFIED

Updated

18 years ago
No longer blocks: 11346
You need to log in before you can comment on or make changes to this bug.