Webpage menus don't show up due to javascript problems

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: dids, Assigned: Arun Ranganathan)

Tracking

({top100})

Details

(Whiteboard: aok, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062823

Bad : Displayed Properly(?) by IE

The left hand of the page shows menu a set of links that should pull up layered
menus. Nothing happens however when you click them.

This may be incorrectly written html. I dont know.


Reproducible: Always
Steps to Reproduce:
1. url www.bigbrother.terra.com
2. click on news ( left hand frame )
3. Nothing happens

Actual Results:  No menu appears

Expected Results:  A pop up menu next to the link should appear

This page also has problems when you click on links in the main window for the
individual stories. Pressing Back doesnt take you back one page

Comment 1

17 years ago
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004001 (NS_ERROR_NOT_IMPLEMENTED)
[nsIEditorShell.GetSelectedOrParentTableElement]"  nsresult: "0x80004001
(NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame ::
chrome://editor/content/editor.js :: goUpdateTableMenuItems :: line 2201"  data: no]

Error: doc.layers has no properties
Source File: http://www.bigbrother.terra.com/includes/dhtmllib.js
Line: 627

Error: redeclaration of const kIOServiceProgID
Source File: chrome://communicator/content/utilityOverlay.js
Line: 1

Reporter, next time please use a better subject

This is a javascript problem, so ->javascript engine for now
There are lots of pages with this problem, but i will let someone else confirm
if they want this one as a new bug or a dupe
Component: Evangelism → Javascript Engine
Summary: I think its a layers problem → Webpage menus don't show up due to javascript problems

Comment 2

17 years ago
Actually this is a problem with the page. documnet.layers is an NS4ism.
Component: Javascript Engine → Evangelism

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Arun, giving you the Linux bugs
Assignee: bclary → aruner

Updated

17 years ago
OS: Linux → All
Hardware: PC → All

Comment 4

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Updated

16 years ago
Keywords: top100

Updated

16 years ago
Blocks: 113492

Comment 5

16 years ago
The site is down, keeping it open though in case it comes back
Whiteboard: aok

Updated

16 years ago
No longer blocks: 113492
not even whois knows the domain any more.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.