Closed Bug 885133 Opened 9 years ago Closed 9 years ago

[B2G][GPS] crash: libgps.utils.so@0x14ae, 2-3 seconds after opening camera

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:leo+)

RESOLVED WORKSFORME
blocking-b2g leo+

People

(Reporter: ndavidson, Assigned: vliu)

Details

(Keywords: crash, regression, reproducible, Whiteboard: [b2g-crash])

Crash Data

Attachments

(5 files)

Description:
When user launches camera app, the screen turns black and device reboots.

Repro Steps:
1) Updated to Unagi Build ID: 20130619070213
2) Tap on a camera button
3) Take a picture with a camera


Actual:
User Is able to take a picture with a camera.

Expected:
Camera App crashes and device is rebooted before user is able to take a picture

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/08cb0fc1e205
Gaia: 6e43018fe137779997211f5dcdfa2ffa7ea5ac8b
Platform Version: 18.0

Notes:
Repro frequency: 100%
Test Suite Name: Sanity test
Q Analysts Team Priority:  Pri 3
Component: Gaia → General
This needs more info:

* Is this consistently reproducible?
* Can you provide a crash report ID?
* Can you provide a logcat?
Severity: normal → critical
Keywords: crash, stackwanted
Whiteboard: [b2g-crash]
This is very likely bug 882328. Please try to repeat this crash with a new build including that patch; if you can, please reopen and provide the information requested in comment 1.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 882328
(In reply to Mike Habicher [:mikeh] from comment #2)
> This is very likely bug 882328. Please try to repeat this crash with a new
> build including that patch; if you can, please reopen and provide the
> information requested in comment 1.
> 
> *** This bug has been marked as a duplicate of bug 882328 ***

Are you sure? This is being reproduced on b2g18, but bug 882328 implies it's central only.
(In reply to Jason Smith [:jsmith] from comment #3)
> 
> Are you sure? This is being reproduced on b2g18, but bug 882328 implies it's
> central only.

Gah, you're right. /me goes for more coffee.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Flags: needinfo?(ndavidson)
Attached file Crash report ID
Flags: needinfo?(ndavidson)
Still need a logcat and indication if this is consistently reproducible.
Flags: needinfo?(ndavidson)
Crash Signature: [@ libgps.utils.so@0x14ae]
Keywords: stackwanted
Confirmed this crash is definitely different. The stack here is in relation to GPS.
Keywords: regression
Given the current information this reads off as a blocker. It's a OS restart crash regression in the GPS area.
blocking-b2g: --- → leo?
Attached file Camera crash Log
Flags: needinfo?(ndavidson)
Flags: needinfo?(ndavidson)
Summary: [B2G][Camera] Camera application crashes after 2-3 seconds after launch. → [B2G][GPS] crash: libgps.utils.so@0x14ae, 2-3 seconds after opening camera
Keywords: reproducible
Looks like camera crashes after receiving request to allow Geo-location tracking 

here is today's crash report: https://crash-stats.mozilla.com/report/index/359bb0be-bc0e-46ef-a445-84df72130620
Flags: needinfo?(ndavidson)
Repro on Today's build - Unagi Build ID: 20130620070209
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/3e144cc723d3
Gaia: c507ff65b51194383da65f8927164f078a3e1f79
Platform Version: 18.0
Using unagi, Mozilla RIL, not able to reproduce on my device using:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/3e144cc723d3
Gaia   c507ff65b51194383da65f8927164f078a3e1f79
BuildID 20130619230208
Version 18.0
Was the bug filed here originally targeted for commercial RIL?
AFAIK all the testing we are doing for the sanity check and the full unagi smoketest run are using the Mozilla RIL.
Triage team needs clarification regarding Comm vs. Moz RIL. Also is this seen on any other devices running V1 train. Adding needs info.
Flags: needinfo?(ndavidson)
Unable to reproduce on Unagi device but able to reproduce on Leo device. 

Device: Unagi phone
Build Identifier: 20130621070212
Update channel: unagi/1.1.0/beta
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be641371823447
Git commit info: 2013-06-21 14:04:07
OS version: 1.1.0.0-prerelease

Device: Leo phone
Build Identifier: 20130621070212
Update channel: leo/1.1/nightly
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be641371823447
Git commit info: 2013-06-21 14:04:07
OS version: 1.1.0.0-prerelease

Steps to reproduce:
1. Long press on the phone home screen. A "Select from" dialog opens with options for Wallpaper, Gallery and Camera.
2. Tap on the Camera option. The Camera app launches and displays the current view in front of the phone camera.

Expected Result:
The Camera app should keep displaying the current view in front of the phone camera till you are ready to take your photo.

Actual Result:
The Camera app freezes after 2 seconds and causes the phone to reboot. (Logcat attached.)
Keywords: qawanted
In triage Swaroopa mentioned this may not be happening on recent builds hence adding qawanted to recheck that before blocking
As pre the comment 17, Issue seems to be reproducible on leo with the Moz RIL.
Keywords: qawanted
This is preventing testing with MozRIL, which we support internally.
Assignee: nobody → kchang
blocking-b2g: leo? → leo+
According to the comment 17, it is the platform dependent issue. 
Vincent, please help this issue.

By the way, after checking the log, I don't think this issue is same as the original one.
Assignee: kchang → vliu
(In reply to Parul Mathur [:pragmatic] from comment #17)
> Created attachment 766211 [details]
> logcat for camera app freeze and phone reboot
> 
> Unable to reproduce on Unagi device but able to reproduce on Leo device. 
> 
> Device: Unagi phone
> Build Identifier: 20130621070212
> Update channel: unagi/1.1.0/beta
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
> Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be641371823447
> Git commit info: 2013-06-21 14:04:07
> OS version: 1.1.0.0-prerelease
> 
> Device: Leo phone
> Build Identifier: 20130621070212
> Update channel: leo/1.1/nightly
> Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
> Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be641371823447
> Git commit info: 2013-06-21 14:04:07
> OS version: 1.1.0.0-prerelease
> 
> Steps to reproduce:
> 1. Long press on the phone home screen. A "Select from" dialog opens with
> options for Wallpaper, Gallery and Camera.
> 2. Tap on the Camera option. The Camera app launches and displays the
> current view in front of the phone camera.
> 
> Expected Result:
> The Camera app should keep displaying the current view in front of the phone
> camera till you are ready to take your photo.
> 
> Actual Result:
> The Camera app freezes after 2 seconds and causes the phone to reboot.
> (Logcat attached.)

I am not clear about the way to reproduce this issue. Before the step 1, which state I should keep on screen? I couldn't see any "Select from" pops up for me.
Flags: needinfo?(parul)
"Long press on the phone home screen." means that you have to put your finger on the home screen and keep it there till a "Select from" dialog pops up. (See screenshot attached.)
Flags: needinfo?(parul)
Use 6/25 build on LEO with comm ril
Gaia:     1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
  B-D     2013-06-25 17:04:16
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
BuildID   20130625070217
Version   18.0

Can't Reproduce this issue
Tried to sync with today's build and can't not reproduce it on leo with the Moz RIL. Reopen it if someone can still reproduce it.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(ndavidson)
You need to log in before you can comment on or make changes to this bug.