Paid apps are showing up in search results

RESOLVED FIXED in 2013-06-27

Status

Marketplace
Search
P2
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa, Assigned: robhudson)

Tracking

2013-06-27
Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:
1. Make sure the flag "allow-paid-app-search" is OFF
2. Approve a paid app
3. Search for the app by its name in one of the supported region

expected behavior:
App doesn't show up in search results

observed behavior:
App shows up
Here's where we do the filtering: https://github.com/mozilla/zamboni/blob/master/mkt/webapps/models.py#L653

So I'm not sure what the problem is, but I can totally reproduce.
Assignee: nobody → robhudson.mozbugs
Priority: -- → P2
Target Milestone: --- → 2013-06-27
(Assignee)

Comment 2

5 years ago
Can you provide an example on -dev that I can look at?

Note that disabling the flag will take 5 minutes for caches to clear.
Flags: needinfo?(krupa.mozbugs)
1) Upload an app in Seville.
2) Approve the app.
3) Go to search results and search for said app.
4) Notice that app shows up in search results.

We experienced this in production, but I've since disabled the paid app that I submitted.
Flags: needinfo?(krupa.mozbugs)
(Assignee)

Comment 4

5 years ago
I see what's happening. I'll try to get a fix up soon.
(Assignee)

Comment 5

5 years ago
Let's try this:
https://github.com/mozilla/zamboni/commit/95643c7
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.