The new tab page is still displayed after the user selected the option to hide it

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
5 years ago
4 years ago

People

(Reporter: illumilore, Unassigned)

Tracking

21 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512193848

Steps to reproduce:

opened a new tab


Actual results:

A bunch of history windows were shown in new tab


Expected results:

history should not be shown in new tab since it was previously turned off.

Comment 1

5 years ago
Hi, unfortunately this report is not very useful because it does not describe the problem well. If you have time and can still reproduce the problem, please read https://developer.mozilla.org/en/Bug_writing_guidelines and add a more useful description to this report.
Flags: needinfo?(illumilore)

Comment 2

5 years ago
Serioulsy ill, it's not the first time you write bug reports with limited details, like in bug 883666. Read the guidelines.
(Reporter)

Comment 3

5 years ago
What more info do you need?
Flags: needinfo?(illumilore)

Comment 4

5 years ago
Did you read https://developer.mozilla.org/en/Bug_writing_guidelines and took a look at your words above?

We miss proper steps to reproduce. Unclear that and when "History was previously turned off", no idea how exactly to turn off history, when exactly you turned off history (same session? months ago?), you likely display some quick links instead of a blank or homepage in a new tab? In short: Your steps and your settings. I cannot reproduce anything if you don't provide proper steps and if my settings completely differ from yours.
Flags: needinfo?(illumilore)

Updated

5 years ago
Component: Untriaged → General
(Reporter)

Comment 5

5 years ago
I have read the link you gave. You can reproduce the bug by opening a new tab, and then the history is displayed when it was previously turned off. To turn off history windows, you click on the tic-tac-toe image in the upper right of a new tab.
Flags: needinfo?(illumilore)

Comment 6

5 years ago
Did you do anything else between hiding the new tab page (or: clicking the tic-tac-toe) and opening a new tab? Can you reproduce the issue in safe mode (http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode)?
Component: General → Tabbed Browser
Flags: needinfo?(illumilore)
Summary: turning off new tab windows resets → The new tab page is still displayed after the user selected the option to hide it

Comment 7

5 years ago
WFM on the 06/26 Nightly. After selecting to hide the new tab page, whenever I open a new tab, a blank page is opened. The blank page does contain the grid (tic-tac-toe) so I can select seeing the new tab page. It's never displayed without me manually selecting that though.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE

Comment 8

5 years ago
ill, FWIW, the new tab pref is browser.newtabpage.enabled

Updated

5 years ago
Duplicate of this bug: 765019
(Reporter)

Comment 10

5 years ago
It does not happen in safe mode, but it does still default to showing the history on new profiles.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(illumilore)
Resolution: INCOMPLETE → ---

Comment 11

5 years ago
(In reply to ill from comment #10)
> It does not happen in safe mode, but it does still default to showing the
> history on new profiles.

It does default to that on new profiles. The idea of testing on a new profile is to do your steps on it. Does this issue reproduce if you turn off history on a new profile, then open about:newtab?
Flags: needinfo?(illumilore)
(Reporter)

Comment 12

5 years ago
"reproduce if you turn off history on a new profile,"

you mean by selecting never use history on the privacy tab in settings?
Flags: needinfo?(illumilore)

Comment 13

5 years ago
(In reply to ill from comment #12)
> "reproduce if you turn off history on a new profile,"
> 
> you mean by selecting never use history on the privacy tab in settings?

You should do the exact same steps as when you reproduced this bug on your profile. According to your previous comments, you just went to about:newtab and clicked the tic-tac-toe to turn it off.
(Reporter)

Comment 14

5 years ago
Doing that makes it stay off on a new profile

Comment 15

5 years ago
(In reply to ill from comment #14)
> Doing that makes it stay off on a new profile

That means this is most probably not a Firefox issue. What prefs did you change from default on your old profile? And what add-ons do you have there?
Flags: needinfo?(illumilore)
Ill, while we appreciate your reporting, a lot of the bugs you report are duplicates, support questions, or result in folks doing QA and bug triage asking you a standard set of questions -- asking for urls, trying to reproduce the issue in safe mode and with a clean profile, asking you to describe the exact steps to reproduce the bug, and so on. 

Can you check the support forums, and then check for duplicate bugs before you open a new bug report? 
And, when you do file, please tell us all the detail you can, in the initial bug report. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago4 years ago
Flags: needinfo?(illumilore)
Resolution: --- → INVALID
(Reporter)

Comment 17

4 years ago
This is not a support question, it is a report for a bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 18

4 years ago
Comment 15 is still unanswered.
Flags: needinfo?(illumilore)
Per bug 1008811 comment 4, I don't think we'll be getting an answer. Marking as incomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(illumilore)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.