Does not update field when choosing.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
7 years ago

People

(Reporter: piotr, Assigned: adamlock)

Tracking

({crash})

Trunk
mozilla0.9.6
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When choosing a product the location-options should be filled with new options.
This does not happen, making it impossible/hard to download the product.

Comment 1

18 years ago
On mozilla0.9.2 win32 selecting in the left select box updates the one in the
right, but it crashes Mozilla.

Comment 2

18 years ago
weird. I can't seem to get it to crash anymore

Comment 3

18 years ago
I manage to crash on that page again with 0.9.2 win32 (after clearing cache a
few times and retrying a few times.)

Comment 4

18 years ago
I also manage to crash.
Win98 BuildID 88522
TalkbackID: TB32364738Y
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
Confirming on WinNT with debug build 2001-06-19. 
I crashed with this stack trace:


nsTimer::~nsTimer() line 122 + 24 bytes
nsTimer::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsTimer::Release(nsTimer * const 0x04ae1c60) line 94 + 151 bytes
nsTimerManager::FireNextReadyTimer(nsTimerManager * const 0x0285faa0, unsigned 
int 0) line 117 + 12 bytes
nsAppShell::Run(nsAppShell * const 0x01002420) line 118
nsAppShellService::Run(nsAppShellService * const 0x01001260) line 418
main1(int 1, char * * 0x00955eb0, nsISupports * 0x00000000) line 1139 + 32 bytes
main(int 1, char * * 0x00955eb0) line 1437 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1ba06()


FUNCTION AT CRASHPOINT:

nsTimer::~nsTimer()
{
  KillOSTimer();
  
  NS_IF_RELEASE(mCallback);    <<<<<<<<<<<<<<<  STOPPED HERE
}
Keywords: crash

Comment 6

18 years ago
Here is the stack trace from the Talkback incident above:


0x024b425c 
nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 419] 
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1168] 
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1467] 
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1485] 
WinMainCRTStartup() 
KERNEL32.DLL + 0x1b537 (0xbff8b537) 
KERNEL32.DLL + 0x1b3e9 (0xbff8b3e9) 
KERNEL32.DLL + 0x19dac (0xbff89dac)

Comment 7

18 years ago
No JS Engine issues apparent here. Based on the stack traces, 
reassigning to Embedding:Docshell for further analysis - 
Assignee: rogerl → adamlock
Component: Javascript Engine → Embedding: Docshell
QA Contact: pschwartau → adamlock

Comment 8

18 years ago
Thought I'd add a talkback ID from a newer nightly build:

build 2001063008 on Win2k (SP2)

Talkback ID: TB32380051W

Also, when I select a product, the other select box does start to change, so the
current summary may be a bit off here.  However, in the process of changing the
other select box, the browser crashes.

Jake
(Assignee)

Comment 9

18 years ago
CC'ing Radha.

I suspect the problem is the history.go(0) which is called as the last action of
ChangeOptions() after the contents of the location dropdown are updated.

If history.go(0) is equivalent to reloading the page, then the problem lies with
the Javascript for doing this.
history.go(0) is equivalent to reloading the page. 
(Assignee)

Comment 11

18 years ago
If history.go(0) is equivalent to reloading the page then it is the fault of the
JS in the page for calling it. It's not a bug in Mozilla.

The page needs to tighten up its sniffer code and should only call history.go(0)
if its running on NS 4.x.

Marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 12

18 years ago
but shouldn't we be avoiding the crash, at least???

I don't see how a crasher is marked "invalid".  Writing to standards is one 
thing, but even totally messed up code shouldn't cause the browser to crash.  
If it goes in an infinite loop and locks up the machine because of stupid 
browser sniffing and bad code, that is one thing, but this thing crashed almost 
immediately when I selected that box.

Bottom line:  It still shouldn't crash mozilla.  

I Recommend a bit of rethinking on this...

jake

Updated

18 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 13

18 years ago
this is a crash => reopen.

asa: can we have another stack trace?

Comment 14

18 years ago
Using build 2001070304 on Win2k (SP2)

Crashed after choosing product (javascript started to make a change to the the 
second dropdown list and then it crashed)

Talkback ID: TB32501150E

Jake

Comment 15

18 years ago
Incident ID 32501150
Stack Signature 0x22bcc0f2 3908e3c4
Bug ID
Trigger Time 2001-07-03 22:49:27
User Comments 1. Load page 2. Select a product from the products dropdown 3.
Javascript changes second dropdown based on first selection 4. Watch Mozilla
crash Jake
Build ID 2001070311
Product ID MozillaTrunk
Platform ID Win32
Stack Trace
0x22bcc0f2
0x02b9e3a1
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 419]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1181]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1481]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1499]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08)
(Assignee)

Comment 16

17 years ago
Page does not crash on a recent trunk build. Likely to be marked WFM
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 17

17 years ago
Marking WFM as previously promised
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.