[memchaser] SDK based add-on got an SDK bump to 1.14 even when opted-out

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Yesterday I got the notification that our SDK based add-on Memchaser got upgraded to SDK 1.14. Not sure why that happened, especially because we have been opted-out from the automatic upgrade.

Also when I tried to check the opt-out settings in the developer pages the checkbox is not shown:
https://addons.mozilla.org/en-US/developers/addon/memchaser/edit

Looks like something is clearly wrong here. Please get this fixed and really don't upgrade the add-on when the developer has opted-out from the process. That completely destroys our internal workflow. Thanks.
I believe this was a one-time thing for addon repacks, right Jeff?
Flags: needinfo?(jgriffiths)
(In reply to Henrik Skupin (:whimboo) from comment #0)
> Yesterday I got the notification that our SDK based add-on Memchaser got
> upgraded to SDK 1.14. Not sure why that happened, especially because we have
> been opted-out from the automatic upgrade.

That automatic upgrade stuff in AMO is dodgy at best, I'd be surprised if it works for anything except add-ons from Builder.

> Also when I tried to check the opt-out settings in the developer pages the
> checkbox is not shown:
> https://addons.mozilla.org/en-US/developers/addon/memchaser/edit

Looks like it was removed then.

> Looks like something is clearly wrong here. Please get this fixed and really
> don't upgrade the add-on when the developer has opted-out from the process.
> That completely destroys our internal workflow. Thanks.

If you haven't been made aware of this, I apologize. The basic facts are that unless you're running SDK >= 1.14, we can't allow you to be compatible with Firefox >= 22, period. Please update memchaser as soon as possible. If you have specific issues that are preventing that, please let me know as soon as possible.

We are also doing this:

https://bugzilla.mozilla.org/show_bug.cgi?id=885381

"Jetpacks built with a version of the SDK earlier than 1.14 will not work with
Firefox 22, so they should be marked incompatible with it."
Flags: needinfo?(jgriffiths)
(Reporter)

Comment 3

6 years ago
(In reply to Jeff Griffiths (:canuckistani) from comment #2)
> (In reply to Henrik Skupin (:whimboo) from comment #0)
> > Yesterday I got the notification that our SDK based add-on Memchaser got
> > upgraded to SDK 1.14. Not sure why that happened, especially because we have
> > been opted-out from the automatic upgrade.
> 
> That automatic upgrade stuff in AMO is dodgy at best, I'd be surprised if it
> works for anything except add-ons from Builder.

Our add-on is not built by the Builder. We build this on our own by using the Add-on SDK.

> > Also when I tried to check the opt-out settings in the developer pages the
> > checkbox is not shown:
> > https://addons.mozilla.org/en-US/developers/addon/memchaser/edit
> 
> Looks like it was removed then.

Any reason for that? Is that a regression?

> > Looks like something is clearly wrong here. Please get this fixed and really
> > don't upgrade the add-on when the developer has opted-out from the process.
> > That completely destroys our internal workflow. Thanks.
> 
> If you haven't been made aware of this, I apologize. The basic facts are
> that unless you're running SDK >= 1.14, we can't allow you to be compatible
> with Firefox >= 22, period. Please update memchaser as soon as possible. If
> you have specific issues that are preventing that, please let me know as
> soon as possible.

Why haven't we sent out emails to add-on authors that we are doing that? That would have helped us to upgrade to 1.14 on our own. But now this version is up on AMO and we cannot go back. So the next version we will release on our own will have included a couple of features and the SDK 1.14 too.

> We are also doing this:
> 
> https://bugzilla.mozilla.org/show_bug.cgi?id=885381
> 
> "Jetpacks built with a version of the SDK earlier than 1.14 will not work
> with
> Firefox 22, so they should be marked incompatible with it."

Why does Memchaser still work in Aurora and Beta which is 23.0 and 24.0? Do we only disable add-ons for releases? I feel that is counter-productive. If add-ons with the SDK <1.14 would not work, we should also mark them as incompatible in Aurora and Nightly builds.
(In reply to Henrik Skupin (:whimboo) from comment #3)

> Any reason for that? Is that a regression?

You'd have to ask AMO people. It never worked well.

> > > Looks like something is clearly wrong here. Please get this fixed and really
> > > don't upgrade the add-on when the developer has opted-out from the process.
> > > That completely destroys our internal workflow. Thanks.
> > 
> > If you haven't been made aware of this, I apologize. The basic facts are
> > that unless you're running SDK >= 1.14, we can't allow you to be compatible
> > with Firefox >= 22, period. Please update memchaser as soon as possible. If
> > you have specific issues that are preventing that, please let me know as
> > soon as possible.
> 
> Why haven't we sent out emails to add-on authors that we are doing that?
> That would have helped us to upgrade to 1.14 on our own. But now this
> version is up on AMO and we cannot go back. So the next version we will
> release on our own will have included a couple of features and the SDK 1.14
> too.

We have sent emails, blogged about it, etc. Again, apologies if none of that has reached you. We emailed the address related to memchaser in AMO, but if you have multiple authors we may have sent the notification to the wrong address.

The original post is here: 

https://blog.mozilla.org/addons/2013/02/26/per-window-private-browsing-and-the-add-on-sdk/

> Why does Memchaser still work in Aurora and Beta which is 23.0 and 24.0? Do
> we only disable add-ons for releases? I feel that is counter-productive. If
> add-ons with the SDK <1.14 would not work, we should also mark them as
> incompatible in Aurora and Nightly builds.

That's exactly what that bug is talking about, and we're doing it for release.
(Reporter)

Comment 5

6 years ago
(In reply to Jeff Griffiths (:canuckistani) from comment #4)
> > Why does Memchaser still work in Aurora and Beta which is 23.0 and 24.0? Do
> > we only disable add-ons for releases? I feel that is counter-productive. If
> > add-ons with the SDK <1.14 would not work, we should also mark them as
> > incompatible in Aurora and Nightly builds.
> 
> That's exactly what that bug is talking about, and we're doing it for
> release.

Well, it would have been better for testing when add-ons bundled with the SDK <1.14 would have been marked as incompatible in Firefox 22.0 when it was in aurora or even nightly stage. That way people would have had enough time to update the SDK version, and to do proper testing. I'm always questioning myself if no regressions are getting introduced by such an automatic version bump.
We opted to instead do outreach about this issue ( add-on developers registered with AMO were all emailed at least once ) and do the compatibility bump later.

As you might be aware, the SDK has gone through some really large changes over the last few months: landed in m-c, per-window private browsing compatibility issues, etc. We've tried to message out to people via the email list and add-ons blog, and by emailing affected developers directly - but this clearly hasn't been perfect.

The good news is - once your add-on is built with 1.14 it will only ever load the SDK modules included with Firefox - this means your compatibility testing complexity is reduced to a question of whether your code is compatible with a given Firefox version.
Looks like there's nothing to be done here. Sorry for any inconveniences.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.