svg feGaussianBlur filter doesn't work on vertical lines

RESOLVED INVALID

Status

()

Core
SVG
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: jlongster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 765468 [details]
test case

I'm trying to use the feGaussianBlur filter in an SVG object on a `line` element. The line happens to be perfectly vertical (case #1), and if I apply the filter to it, in Firefox the line completely disappears. If I tilt it just so slightly (case #2), the blur only happens on the edges. If it's slanted (case #3), it works fine.

I think this might be connected to how the gaussian blur works, but in Chrome the vertical line renders fine. Strangely, case #2 renders the same in Chrome (only some edges are blurred).

That's the best description I can give. I've attached a test case that shows the error in all versions of Firefox, but works in latest Chrome.
If attribute ‘filterUnits’ is not specified, then the effect is if a value of 'objectBoundingBox' were specified.

Then check http://www.w3.org/TR/SVG/coords.html#ObjectBoundingBox which says

Keyword objectBoundingBox should not be used when the geometry of the applicable element has no width or no height, such as the case of a horizontal or vertical line, even when the line has actual thickness when viewed due to having a non-zero stroke width since stroke width is ignored for bounding box calculations. When the geometry of the applicable element has no width or height and objectBoundingBox is specified, then the given effect (e.g., a gradient or a filter) will be ignored.

So you should report that as a Blink bug as we're following the SVG specification here.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
You just made my day. That works, thanks! I'll try to file a bug for Blink if I can find their bug tracker.
http://code.google.com/p/chromium/issues/entry?template=Defect%20on%20Windows&comment=Chrome+Version+++++++%3A+%3CCopy+from%3A+%27about%3Aversion%27%3E%0AOS+Version%3A+6.0+%28Windows+Vista%2C+Windows+Server+2008%29%0AURLs+%28if+applicable%29+%3A%0AOther+browsers+tested%3A%0A++Add+OK+or+FAIL+after+other+browsers+where+you+have+tested+this+issue%3A%0A+++++Safari+5%3A%0A++Firefox+4.x%3A%0A+++++IE+7%2F8%2F9%3A%0A%0AWhat+steps+will+reproduce+the+problem%3F%0A1.%0A2.%0A3.%0A%0AWhat+is+the+expected+result%3F%0A%0A%0AWhat+happens+instead+of+that%3F%0A%0A%0APlease+provide+any+additional+information+below.+Attach+a+screenshot+if%0Apossible.%0A%0A
Hmm, looks like it's guessed lots of stuff based on my OS and bunged it in the URL so you'll have to adjust apporpriately.

Updated

2 years ago
Duplicate of this bug: 1217317
You need to log in before you can comment on or make changes to this bug.