If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

New location on return disabled while JavaScript loop running.

VERIFIED WORKSFORME

Status

SeaMonkey
Location Bar
VERIFIED WORKSFORME
17 years ago
4 years ago

People

(Reporter: Brent Gustafson, Assigned: Joe Hewitt (gone))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If you go to the above link, it moves several images of blocks around the screen
using a recursive function.  I've noticed that while this annimation is going
on, and if I try to type in a new URL to go to (say, cnn.com), I can type a new
URL in just fine, but using the return key to "submit" it to go there does not
work.  Thus I am stuck on this page.

Using a G3 350mhz, 192mb ram (28.2mb allocated to mozilla), and running Mozilla
0.9.2 (build id: 2001062823) on MacOS 9.1.

I'd also like to note how slow the annimation of multiple objects in Mozilla is.
 Check the page out in IE5/Win to see how fast it should be running.
- occurs on Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628

The Location bar autocomplete doesn't work either.

Comment 2

16 years ago
confirming build 2001072603 win32
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I see this on WinNT, but only after I leave the animation running for a while.

Comment 4

16 years ago
urlbar
Assignee: asa → alecf
Component: Browser-General → URL Bar
QA Contact: doronr → claudius

Comment 5

16 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross

Comment 6

16 years ago
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt
(Assignee)

Comment 7

16 years ago
works 4 me
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.