Closed Bug 885543 Opened 8 years ago Closed 8 years ago

[Australis] after customization there is a left over grey bar in the title bar

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: evold, Assigned: mstange)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P2])

Attachments

(3 files)

See attached screenshots
Hey Markus,

Is it possible that the titlebar isn't being properly invalidated after exiting customization mode?

-Mike
Flags: needinfo?(mstange)
Yes, something like that. I'll look into it.
Assignee: nobody → mstange
Flags: needinfo?(mstange)
Saw the same problem, build rev d50bbe2d9772.
Triaging this all by myself to P2, but feel free to change it! Why? This is happening for me as well EACH time I leave cust mode.
Whiteboard: [Australis:P2]
I debugged this but I don't have an idea for a good solution yet.
The gradient is made up by a 9px high -moz-appearance:-moz-window-titlebar box at the top and a -moz-appearance:toolbar box (a ::before pseudo-element somewhere) under it. When the titlebar box is painted, it knows that there's a toolbar under it so it only draws the beginning of a longer gradient, and the rest of the gradient is drawn by the toolbar. During customization, the toolbar box is hidden (or loses its -moz-appearance, not sure), so the titlebar only draws a 9px high gradient with a separator line. This gradient isn't visible because the customization area covers it. On exiting customization mode, the titlebar is uncovered before the toolbar box has been restored, so this too-short gradient becomes visible and is not extended because there's no toolbar to connect it to. Slightly later the toolbar box is put in its old place and given back -moz-appearance:toolbar, which should it make connect to the titlebar visually. Unfortunately, the titlebar is not invalidated by this change, so it keeps its old appearance with the too-short gradient.

We could avoid this by setting the titlebar box size to the full gradient height, always. Then it wouldn't need to change dependent on what happens below it with the toolbar box. We want this anyway for bug 851652, but we haven't resolved the question of how TabsInTitlebar._update should be involved in it yet, see the discussion starting at bug 851652 comment 108.
Duplicate of this bug: 863907
So I've seen this before, but hadn't seen this in quite a while. So I tried to regression-hunt this and couldn't reproduce all the way back to July 1st. Are there specific steps to reproduce, or is it seemingly random? Mike, you were seeing this every time - are you still? And/or can you reproduce on a clean profile? Just trying to figure out what's going on here. :-)
Flags: needinfo?(mdeboer)
No, I can not reproduce this anymore.

/me happy camper
Flags: needinfo?(mdeboer)
Then I'll tentatively resolve WFM. Please feel invited to reopen if anyone still sees this on a recent UX nightly, if possible with explicit steps to reproduce.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.