Database error (PostgreSQL) when editing user: value too long

RESOLVED DUPLICATE of bug 484206

Status

()

Bugzilla
Database
RESOLVED DUPLICATE of bug 484206
5 years ago
4 years ago

People

(Reporter: Marco Aurélio Graciotto Silva, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130516103852

Steps to reproduce:

I'm using Bugzilla 4.4, Apache 2.4.4, PostgreSQL 9.2.4, perl-DBD-Pg 2.19 (Fedora 18).

I changed my user profile, assigning every possible permission. It's not a big Bugzilla installation (actually, I use it in a classroom setting). However, when I saved the changes, a software error occurred.




Actual results:

A simple web page was shown with the error message. The errors is related to the database statement. 

DBD::Pg::db do failed: ERROR:  value too long for type character varying(255) [for Statement "INSERT INTO profiles_activity (
                           userid, who,
                           profiles_when, fieldid,
                           oldvalue, newvalue
                          ) VALUES (
                           ?, ?, now(), ?, ?, ?
                          )
                   "] at /var/www/html/bugzilla/editusers.cgi line 325, <DATA> line 558.


Expected results:

I suspect that the information regarding this change of my profile was bigger than supported by the 'newvalue' field of 'profile_activity' (some of the groups have a quite large name...). As the DB statement failed, no change was done (my permissions are the same after the error).

I can workaround this by adding the permission in two steps (half now, half next time), but it would be nice if Bugzilla could avoid this, either by truncating the logged that (not exactly the best solution), by splitting the record in several ones (properly linked) or by changing the field type.

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484206
You need to log in before you can comment on or make changes to this bug.