URL autocomplete should consider the URL's structure

RESOLVED DUPLICATE of bug 78270

Status

RESOLVED DUPLICATE of bug 78270
18 years ago
14 years ago

People

(Reporter: ilya.konstantinov+future, Assigned: hewitt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This bug is a proposed usability enhancement.

For example: After browsing both "bugzilla.mozilla.org" and "bugzilla.gnome.org"
for a while, the user types in "bugzilla." in the URL bar. The suggested URLs
are, in the exact order:
http://bugzilla.gnome.org/query.cgi
http://bugzilla.gnome.org/enter_bug.cgi
http://bugzilla.gnome.org
http://bugzilla.mozilla.org/files/
http://bugzilla.mozilla.org/files/help.html
http://bugzilla.mozilla.org/query.cgi
http://bugzilla.mozilla.org/enter_bug.cgi

When there are many visited pages within both domains, the user cannot quickly
access the second domain without typing in it's beggining. The sorting function
should take the URL structure into account, rather than simply sorting
alphabetically. It should present the URLs up to a delimiter (either "/" or "?")
first, and only then their variations. In our example, it'll sort the list as:
http://bugzilla.gnome.org
http://bugzilla.mozilla.org/
http://bugzilla.gnome.org/query.cgi
http://bugzilla.gnome.org/enter_bug.cgi
http://bugzilla.mozilla.org/files/
http://bugzilla.mozilla.org/query.cgi
http://bugzilla.mozilla.org/enter_bug.cgi
http://bugzilla.mozilla.org/files/help.html

(notice the ".../files/help.html" URL was also moved to the bottom, since the
items with nothing after the delimiter are sorted to appear first)
(Assignee)

Comment 1

18 years ago

*** This bug has been marked as a duplicate of 78270 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
The "duplicate" mark is a bit inaccurate, since my bug is about sorting by URL 
structure while the other bug is about sorting by most frequently visited URL. 
The best way is still up to decision of a UI expert, but why discorage my 
offer as a "duplicate" while it isn't?
(Assignee)

Comment 3

18 years ago
We only need one bug for deciding how to sort the autocomplete results.  The
suggestions in this bug will certainly be considered.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.