[Messages] MMS doesn't support sending and receiving vCard attachments

RESOLVED DUPLICATE of bug 849729

Status

P1
normal
RESOLVED DUPLICATE of bug 849729
5 years ago
5 years ago

People

(Reporter: mbarone976, Assigned: borjasalguero)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: MMS_TEF)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR

The messaging client should be able to save vCard attachments received via messaging to the Address Book (Merge with existing entry). 

1. In Client A, compose a contact with details on Contacts/Phonebook section and send via MMS to Client B. 
2. In Client B, save vCard attachments received via messaging to the Address Book. 
3. In Client B, compose a contact with details on Contacts/Phonebook section and Send via MMS to Client A. 
4. In Client A, save vCard attachments received via messaging to the Address Book 

EXPECTED RESULT
The vCard must be saved correctly

Certification Blocker
(Assignee)

Comment 1

5 years ago
Sergi! I know that you were working with vCard in FTU, could you help us with this? THanks!! Gracias! ;)
Flags: needinfo?(sergi.mansilla)
Hi Borja,

What are the current results? I only see the expected ones there. Is the flow complete and just not saving?
Flags: needinfo?(sergi.mansilla)
(Assignee)

Comment 3

5 years ago
We would need to add vCard support to MMS, and it's a CERTIF. Blocker. I've seen that you were adding this feature to FTU, so if you have free cycles could be a good idea if you could help us with this!
Ah, I see! Definitely. I am currently solving a parsing bug there (https://bugzilla.mozilla.org/show_bug.cgi?id=878820). I'll let you know when I am finished with it (hopefully today) and I can assist you with the MMS stuff.

Cheers!

Sergi

Updated

5 years ago
Assignee: nobody → fbsc
blocking-b2g: leo? → leo+

Comment 5

5 years ago
(In reply to Sergi Mansilla from comment #2)
> Hi Borja,
> 
> What are the current results? I only see the expected ones there. Is the
> flow complete and just not saving?

Current rusult is that you receive a MMS containing a vCard as an empty MMS (only text is shown). Please see attached screenshot of a MMS with vCard received.

Comment 6

5 years ago
Created attachment 766562 [details]
MMS with vCard is not received properly
Sorry, I realized after I hit save that we need to decide which to close. It's unclear because this ticket has attachments and additional information that the other ticket does not have.
(In reply to Rick Waldron from comment #7)
> This is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=823513
IMHO, the bug you suggest is a different thing. They do not talk about MMS and Vcard files.

I do think this bug is well described and has a clear scenario for testing.
(In reply to Beatriz Rodríguez [:brg] from comment #9)
> (In reply to Rick Waldron from comment #7)
> > This is a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=823513
> IMHO, the bug you suggest is a different thing. They do not talk about MMS
> and Vcard files.
> 
> I do think this bug is well described and has a clear scenario for testing.

Olli, can you confirm this? Is bug 823513 about sending contacts by way of vcard?
Flags: needinfo?(bugs)
(Assignee)

Comment 11

5 years ago
Hi Rick,
We have some work done in FTU by Sergi (there we have vCard import from SD Card) so we could take a look there. If you want we could mark 823513 as DUP of this one, and if you have free cycles you can assign this to you, Wdyt?
Flags: needinfo?(waldron.rick)
bug 823513 is about receiving contacts using SMS. IIRC vcard is used as the file type..
Flags: needinfo?(bugs)
Olli, thank you for confirming!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(waldron.rick)
Resolution: --- → DUPLICATE
Duplicate of bug: 823513
I meant to do that the other way around.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 823513

Updated

5 years ago
blocking-b2g: leo+ → koi?
Whiteboard: MMS_TEF,TaipeiWW → MMS_TEF

Updated

5 years ago
Priority: -- → P1
Partners agree to not block on this for leo. move to koi.
will form of part of comms backlog for koi.
Blocks: 891754
blocking-b2g: koi? → ---
Updated title to match the vCalendar ticket
Summary: [MMS] Saving vCard attachment is not working → [Buri][Messages][GCF] MMS doesn't support sending and receiving vCard attachments
Requesting koi+ because bug 905548 is also koi+
blocking-b2g: --- → koi?
Summary: [Buri][Messages][GCF] MMS doesn't support sending and receiving vCard attachments → [Messages] MMS doesn't support sending and receiving vCard attachments
add to backlog 891754
blocking-b2g: koi? → ---
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 849729
No longer blocks: 891754
Vicamo, could be useful to keep this bug for the MMS part of bug 849729 ?
(In reply to Julien Wajsberg [:julienw] from comment #22)
> Vicamo, could be useful to keep this bug for the MMS part of bug 849729 ?

For Gecko, there is no more jobs to do for vCard/vCalendar.  Like all other mime types, they're just types with different string texts for MMS API.  So, my understanding is vCard/vCalendar are pure-Gaia features, unless we're going to create some vCard/vCalendar specific APIs.

Besides, the reason khu created bug 849729 is exactly MMS.  That's why he said "for conformance" in bug description.
ok, then I'm changing components there.
And Julien, I set project flags for this bug (and a few other bugs) to reduce open, duplicating bugs.  If you feel otherwise and think they can be amended to have some extra meanings, I'm glad to revert them back.  Just want to have a more clear view of current status :)
Yep, and I'm glad you do this :)

Comment 27

5 years ago
For tracking purposes - 
A user on the English SUMO forums is asking about this feature: https://support.mozilla.org/en-US/questions/1000847
Ralph, this bug is a dupe, would you mind putting your useful comment in bug 849729?
You need to log in before you can comment on or make changes to this bug.