network.http.max-connections-per-server has no effect

RESOLVED WONTFIX

Status

()

Core
Networking
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Sebastian, Unassigned)

Tracking

14 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.34 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 765900 [details]
twoStreams.pcapng

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:14.0) Gecko/20100101 Firefox/14.0.1 (Beta/Release)
Build ID: 20120713134347

Steps to reproduce:

set network.http.max-connections-per-server to 1
set network.http.max-persistent-connections-per-server to 1

I tried to open a webpage over a small datarate and high latency connection



Actual results:

Firefox opened two TCP sockets, one for data transfer from the webserver and one which has no payload data.
you can check within the attached wireshark trace


Expected results:

Firefox should open only a single connection, b/c the second TCP socket has an overhead of around 600Bytes which overloads the connection (only a few kB/s)
(Reporter)

Comment 1

5 years ago
The same issue could be also reproduced on win xp
That's the syn-retry logic.. its being activated because your latency is so huge.. we do allow a tiny burst above the max-connection config to support it.

A setup where 600 bytes overloads a connection is not a use case we can try and support in firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

5 years ago
Thx for the quick reply!
Maybe you should consider re-naming the parameter to average-connections-per-server
you can try setting network.http.connection-retry-timeout to 0 (that disables it).
(Reporter)

Comment 5

5 years ago
THANKS! This is working as expected (at least on the mac x) . Now we can use firefox within the limited network environment!
You need to log in before you can comment on or make changes to this bug.