"Remix" from Tools page should only load templates from selected tool

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: laura, Assigned: daleee)

Tracking

Details

(Whiteboard: s=20130722 p=1)

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
kate
: review+
Details | Review | Splinter Review
(Reporter)

Description

5 years ago
https://webmaker.org/tools 

Reported by user:

https://webmaker.org/tools shows Popcorn and Thimble, and it says to start from scratch or remix, when you click on the remix for Popcorn, it seems to give you the Thimble templates – this is confusing for the user
Perhaps we can also make a search result for a specific template, so that when they click on remix on thimble then it only displays the thimble template
(Reporter)

Comment 2

5 years ago
Checking status here. 

I have mentors needing/wanting to link only to Thimble or only to Popcorn makes. Can't search by tag, is there a search workaround I can share?

Comment 3

5 years ago
Dale, I don't suppose there's an app tag we can add here, is there?
Assignee: nobody → dale
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
(In reply to Jon Buckley [:jbuck] from comment #3)
> Dale, I don't suppose there's an app tag we can add here, is there?

App tag, no. There *is* contentType as an option when using the makeAPI client to perform a search:

eg: contentType: "application/x-popcorn

This is how we use the filter on the front page, so I don't see why we couldn't use contentType to get only popcorn or thimble makes.
(Assignee)

Comment 5

5 years ago
Created attachment 778523 [details] [review]
Code Review

https://github.com/mozilla/webmaker.org/pull/279
Attachment #778523 - Flags: review?(kate)
(Assignee)

Updated

5 years ago
Whiteboard: s=20130722 p=1
(Assignee)

Comment 6

5 years ago
Updated PR, ready for another pass:

https://github.com/mozilla/webmaker.org/pull/279
Comment on attachment 778523 [details] [review]
Code Review

One more nit
Attachment #778523 - Flags: review?(kate) → review+

Comment 8

5 years ago
Commits pushed to master at https://github.com/mozilla/webmaker.org

https://github.com/mozilla/webmaker.org/commit/5238aebf8401775a799c059ee273fae61042a943
[bug 885719] tools remix now sends user to correct search page

https://github.com/mozilla/webmaker.org/commit/1384e3c352f7c04816cea05fdaa2019cddef971d
Merge pull request #279 from daleee/885719-tools-remix-buttons-sends-to-proper-page

[bug 885719] tools remix now sends user to correct search page
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 896675
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.