JS error in LWT code when leaving customization mode

RESOLVED DUPLICATE of bug 884120

Status

()

RESOLVED DUPLICATE of bug 884120
5 years ago
5 years ago

People

(Reporter: mikedeboer, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M?])

Attachments

(1 attachment)

STR:

1. Go into Customization Mode on Mac OSX UX Nightly, without any LWT applied
2. Leave Customization mode
3. Check your console to find the following error:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "themeData is null" {file: "chrome://browser/content/browser.js" line: 616}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: resource://gre/modules/LightweightThemeManager.jsm :: _notifyWindows :: line 713"  data: yes]
************************************************************

I also noticed a visual artifact left behind in the titlebar that disappears when I hover it with my mouse.
Created attachment 765926 [details]
Showing the glitch/ artifact

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 884120
You need to log in before you can comment on or make changes to this bug.