Migrate /community/directory.html to bedrock

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: hoosteeno, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1413780] , URL)

Attachments

(1 attachment)

This file is created by a script that :cmore maintains and runs manually now and then. We should figure out how to get it into bedrock. It probably depends on the publishing solution in bug 874137.
Once the content is migrated we'll need to delete it from SVN. If it's the last thing in the community directory, we should also delete /community.
Marking as a dup of Bug 906879.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 874137
Resolution: --- → DUPLICATE
Duplicate of bug: 906879
I don't agree that this is a duplicate of bug 906879. This bug will be resolved when community/directory.html no longer exists in SVN and PHP. We may choose to delete it if a comprehensive sitemap emerges from bug 906879, but building such a sitemap will not automatically resolve this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
See Also: → bug 906879
Cmore:  Can we move this data source to publish to Bedrock?
Flags: needinfo?(chrismore.bugzilla)

Comment 5

5 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #4)
> Cmore:  Can we move this data source to publish to Bedrock?

I haven't ran the script for quite a while to generate the html. I'm leaning toward either just having a static page on bedrock that can be updated by others via pull requests or we use nucleus so that the data can be managed separately. The content on the directly is pretty structured as it just domain and description. Probably just a static bedrock page will be suffice as nucleus seems overkill. David Boswell was the owner of the content.

David: Are you still the own of the directory? If not, who is? Secondly, are you fine with having the page being in github and either doing a bug+pull request to add/remove a site?
Flags: needinfo?(chrismore.bugzilla) → needinfo?(dboswell)

Comment 6

5 years ago
(In reply to Chris More [:cmore] from comment #5)
> David: Are you still the own of the directory? If not, who is? Secondly, are
> you fine with having the page being in github and either doing a bug+pull
> request to add/remove a site?

I still care about this content -- it's part of the transparency we need to have to let people discover contribution opportunities.

I'm fine with maintaining this however makes the most sense and I'm fine with any recommendations about the best place for this to live either on www.mozilla.org or another Mozilla site.
Flags: needinfo?(dboswell)
Thanks for your reply, David.

Hi Steven-

Could you please migrate this one to Bedrock as a static page?  We'll update it via bugs and PRs going forward.

Thx,
Jen
Flags: needinfo?(steven)
(Assignee)

Comment 8

5 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #7)
> Could you please migrate this one to Bedrock as a static page?  We'll update
> it via bugs and PRs going forward.

Sure, I'll
Flags: needinfo?(steven)
Whiteboard: [kb=1413780]
(Assignee)

Comment 9

5 years ago
Sure, I'll add it to the list.

cmore mentioned a script: Chris where does the source data for the script come from, or should I just work without outputted HTML (which is probably fine)? Thanks.
Assignee: nobody → steven
Flags: needinfo?(chrismore.bugzilla)
OS: Mac OS X → All
Hardware: x86 → All

Comment 10

5 years ago
(In reply to Steven Garrity [:sgarrity] from comment #9)
> Sure, I'll add it to the list.
> 
> cmore mentioned a script: Chris where does the source data for the script
> come from, or should I just work without outputted HTML (which is probably
> fine)? Thanks.

sgarrity: brace yourself with what you are about to see. :) Here's the repo:

https://github.com/chrismore/Domain-Name-Status-Checker

check.sh runs, runs get-input.sh to grab list of websites from https://wiki.mozilla.org/Websites/Domain_List/http, forks check-domain.sh for each domain in the list, check-domain.sh does all bunch of sh magic and has a bunch of separate scripts to do various checking and verification. After it is all over, I get output.txt that has all of domains and their status codes. I then run create-wiki.sh that takes all of output.txt as input and runs a bunch of other script against it to create a bunch of output-[something].txt files used to create wiki pages like:

https://wiki.mozilla.org/Websites/Domain_List
https://wiki.mozilla.org/Websites/Domain_List#Statistics (sub wiki pages)

Then when I want to create the directory.html page, I run the script called create-directory.sh that takes the output-prod.txt file created by create-wiki.sh and it creates output-directory.txt, which is the HTML body contents used on mozilla.org. It also creates this page: https://wiki.mozilla.org/Websites/Domain_List/Community_Owned

.... this is why I said brace yourself. :)
Flags: needinfo?(chrismore.bugzilla)
(Assignee)

Comment 11

5 years ago
I'm glad to port this page to Bedrock, but I did wonder if it might be well suited for wiki.mozilla.org. I could port it there instead.

Comment 12

5 years ago
David: Is there any objections to having this community page being on the public wiki? It would be easier to update and maintain on the wiki than doing pull requests and merges.
Flags: needinfo?(dboswell)

Comment 13

5 years ago
(In reply to Chris More [:cmore] from comment #12)
> David: Is there any objections to having this community page being on the
> public wiki? It would be easier to update and maintain on the wiki than
> doing pull requests and merges.

Managing it on the wiki seems fine.  My concern would just be discoverability.  If we move it, could we make sure we are linking to it on www.mozilla.org in a place people will be able to find it?
Flags: needinfo?(dboswell)
(Assignee)

Comment 14

5 years ago
I have added a copy of the page to the wiki: https://wiki.mozilla.org/Websites/Directory

I've done some searching for links to the Websites Directory page, and the most prominent link seems to be in Tabzilla. Beyond that, there are handful of obscure links, and a few redirects pointing to this page.

I would propose we update the Tabzilla link and the redirects, and redirect mozilla.org/community/directory.html to the new Wiki page.

Sound ok?

Comment 15

5 years ago
(In reply to Steven Garrity [:sgarrity] from comment #14)
> I have added a copy of the page to the wiki:
> https://wiki.mozilla.org/Websites/Directory
> 
> I've done some searching for links to the Websites Directory page, and the
> most prominent link seems to be in Tabzilla. Beyond that, there are handful
> of obscure links, and a few redirects pointing to this page.
> 
> I would propose we update the Tabzilla link and the redirects, and redirect
> mozilla.org/community/directory.html to the new Wiki page.
> 
> Sound ok?

Yeah, it is mainly tabzilla. I would put in  PR to adjust tabzilla and 301 redirect the mozilla.org page to the wiki. I think it looks good on the wiki and Dave and others can control it directly without having to jump through process hoops.

David: are you good here?
Flags: needinfo?(dboswell)

Comment 16

5 years ago
Looks good to me.  Thanks for moving it and I agree that it will be easier to keep updated here.
Flags: needinfo?(dboswell)
(Assignee)

Comment 17

5 years ago
Redirects ported to Bedrock and tabzilla link updated in: https://github.com/mozilla/bedrock/pull/2112

Once that PR is merged and pushed, I can remove the old file and redirects from SVN.
(Assignee)

Comment 18

5 years ago
Created attachment 8446086 [details] [diff] [review]
Patch to remove /community/directory.html redirects

Once that PR is merged and in production, this patch will remove the redundant redirects from the .htaccess file in the mozilla.org SVN repo.
Attachment #8446086 - Flags: review?(pmac)

Comment 19

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/3b0191ad10fcdd2bbbe0c77e14c1e7c6bac18c1f
Redirect websites directory page for Bug 885797
Also update tabzilla link to the same page and consolote redirects from svn

https://github.com/mozilla/bedrock/commit/f7649adce034228ffaae0cb9c964d59ad882ae03
Merge pull request #2112 from sgarrity/bug-885797-websites-directory

Redirect websites directory page for Bug 885797
(Assignee)

Comment 20

4 years ago
(In reply to [github robot] from comment #19)
> Commits pushed to master at https://github.com/mozilla/bedrock

Thanks, robot. Now just need the patch on comment #19 to be reviewed.
Comment on attachment 8446086 [details] [diff] [review]
Patch to remove /community/directory.html redirects

Review of attachment 8446086 [details] [diff] [review]:
-----------------------------------------------------------------

Proceed!
Attachment #8446086 - Flags: review?(pmac) → review+
(Assignee)

Comment 22

4 years ago
Merged in r130037. Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.