Closed Bug 885887 Opened 7 years ago Closed 7 years ago

GenerationalGC: Assertion failure: isTenured(), at gc/Heap.h

Categories

(Core :: JavaScript Engine, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 885607

People

(Reporter: gkw, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file stack
The upcoming testcase crashes js debug shell (tested with a threadsafe deterministic 32-bit debug build) on m-i changeset 7addaeb4e9ad without any CLI arguments at Assertion failure: isTenured(), at gc/Heap.h

CC="gcc -m32" AR=ar PKG_CONFIG_LIBDIR=/usr/lib/pkgconfig CXX="g++ -m32" sh configure --target=i686-pc-linux --enable-optimize --enable-debug --enable-profiling --enable-gczeal --enable-debug-symbols --enable-methodjit --enable-type-inference --disable-tests --enable-more-deterministic --enable-exact-rooting --enable-gcgenerational --enable-threadsafe

(you may need --with-system-nspr)
I got different assertions with opt and debug builds, but both of them were resolved by bug 885607.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 885607
You need to log in before you can comment on or make changes to this bug.