Buttons along top, right are not showing up to enable login

VERIFIED DUPLICATE of bug 69833

Status

VERIFIED DUPLICATE of bug 69833
17 years ago
3 years ago

People

(Reporter: richard.s.hall, Assigned: rods)

Tracking

({ecommerce})

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

I assume that this is some sort of JavaScript evangelism issue, but I will
report it as a bug and hopefully someone can determine if this is true.

The above URL displays a window with two text fields and three buttons.  The
buttons should appear at the top, on the right side in a single column, but they
do not appear.  This makes it difficult to log in to my bank account.  :^)

Reproducible: Always
Steps to Reproduce:
1.  Go to the URL.
2.  Look at the window that pops up.


Actual Results:  You don't see any buttons in the window.

Expected Results:  You should see three buttons in a single column at the top,
right.
(Reporter)

Comment 1

17 years ago
Please notice that the URL is "https"...not that this should make a difference,
but the Bugzilla Helper didn't recognize "https" and prepended "http://" to the
URL, so I had to edit the URL again.

Comment 2

17 years ago
makingtest bugzilla@uxp.de

Comment 3

17 years ago
A better URL to start with is https://secure.advance-bank.de/logon.jsp since you
can avoid the javascript-window and the frameset this way.

The problem resides in https://secure.advance-bank.de/IE/advance.js in the code
used to display the 3 buttons :

function setButton( Name, Bstyle )
{
 var coll = document.all.tags("div")
 if (coll!=null) {
  for (i=0; i<coll.length; i++) 
  if (coll[i].name == Name) {
   coll[i].style.visibility = Bstyle;
  }
 }
}
Since Mozilla doesn't know anything about this (MS-)proprietary document.all no
button ever gets displayed.
Very interesting is that Netscape 4.77 can display the buttons if Javascript is
enabled.
Requesting move to Browser/Evangelism and requesting adding the ecommerce keyword.

Comment 4

17 years ago
thanks for debugging.
Status: UNCONFIRMED → NEW
Component: HTML Form Controls → Evangelism
Ever confirmed: true
Keywords: ecommerce

*** This bug has been marked as a duplicate of 69833 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 7

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.