Last Comment Bug 885941 - Please update all links in Firefox for Android privacy policy to redirect to https://www.mozilla.org/en-US/legal/privacy/firefox.html
: Please update all links in Firefox for Android privacy policy to redirect to ...
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
-- normal (vote)
: Firefox 25
Assigned To: Chris Kitching [:ckitching]
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks: 885895
  Show dependency treegraph
 
Reported: 2013-06-21 17:17 PDT by Jishnu Menon :jishnu
Modified: 2016-07-29 14:33 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
verified


Attachments
Patch homogenising privacy links (1.30 KB, patch)
2013-06-25 16:45 PDT, Chris Kitching [:ckitching]
margaret.leibovic: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description User image Jishnu Menon :jishnu 2013-06-21 17:17:56 PDT
Hi - 

There are several linked privacy policies in Fennec - all should point to https://www.mozilla.org/en-US/legal/privacy/firefox.html (except in Health Report which should go to the specific section in the same policy).
Comment 1 User image Aaron Train [:aaronmt] 2013-06-22 10:12:54 PDT
Is this bug referring to the URL assigned to app.privacyURL?
Comment 2 User image :Margaret Leibovic 2013-06-24 08:51:38 PDT
We did update the link in about:rights in bug 874888, but Aaron is correct that we need to update the app.privacyURL pref, which is used in about:firefox.

Jishnu, do you know of any other in-product privacy links we may have missed?

I'm going to steal this as a good first bug for the intern we have starting today.
Comment 3 User image Chris Kitching [:ckitching] 2013-06-25 16:45:53 PDT
Created attachment 767507 [details] [diff] [review]
Patch homogenising privacy links

The actual URL we´re after here is `https://www.mozilla.org/legal/privacy/firefox.html`, as the website does slightly clever redirection to go to the appropriate locale (And we don´t want to redirect everyone to the en-US version).
There was one incorrect URL - patch attached.
Comment 4 User image :Margaret Leibovic 2013-06-25 17:30:08 PDT
Comment on attachment 767507 [details] [diff] [review]
Patch homogenising privacy links

(When requesting review, you should specify a reviewer. In this case, it's me :)
Comment 5 User image :Margaret Leibovic 2013-06-25 17:49:17 PDT
Comment on attachment 767507 [details] [diff] [review]
Patch homogenising privacy links

Looks good to me!
Comment 6 User image :Margaret Leibovic 2013-06-25 17:50:23 PDT
I'm setting the checkin-needed keyword on this bug, which means that a kind soul with commit access will come along and land this patch for you :)
Comment 7 User image Chris Kitching [:ckitching] 2013-06-25 17:53:17 PDT
Thanks - I did add you as the reviewer, but I used your email address not your name, causing bugzilla to blithley inform me itś truncated the field and carried on. Whoops.
Comment 8 User image Ryan VanderMeulen [:RyanVM] 2013-06-26 06:47:37 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/4e41ddaef7c0
Comment 9 User image :Margaret Leibovic 2013-06-26 09:08:42 PDT
(In reply to Chris Kitching from comment #7)
> Thanks - I did add you as the reviewer, but I used your email address not
> your name, causing bugzilla to blithley inform me itś truncated the field
> and carried on. Whoops.

You need to use the bugzilla id of the reviewer, which is an email address. Pro tip: Many people also add handle shortcuts to their name to make autocomplete easier (e.g. for me, you can just type ":marg" and I'll be the only result that comes up :).
Comment 10 User image Ryan VanderMeulen [:RyanVM] 2013-06-26 13:41:00 PDT
https://hg.mozilla.org/mozilla-central/rev/4e41ddaef7c0
Comment 11 User image Erin Lancaster [:elan] 2013-07-01 16:04:04 PDT
How uplift-able is this? I'm thinking since we are shipping FHR for the first time in Fx23, we might need this as far up as beta for consistency.
Comment 12 User image :Margaret Leibovic 2013-07-01 16:48:52 PDT
(In reply to Erin Lancaster [:elancaster] from comment #11)
> How uplift-able is this? I'm thinking since we are shipping FHR for the
> first time in Fx23, we might need this as far up as beta for consistency.

This is totally upliftable, since it's a pref, not a string. Want me to request uplift?

(The patch for bug 874888 is also good to uplift, since the URL there is just hardcoded into some HTML.)
Comment 13 User image Erin Lancaster [:elan] 2013-07-02 09:00:13 PDT
Yes, let's request uplift for both. (thank you!).
Comment 14 User image :Margaret Leibovic 2013-07-02 10:30:02 PDT
Comment on attachment 767507 [details] [diff] [review]
Patch homogenising privacy links

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this isn't a regression, but we'd like to uplift it because FHR will be part of 23, and we want users to be able to access privacy policies easily
User impact if declined: privacy policies are incorrectly linked
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low risk, just updates a link URL
String or IDL/UUID changes made by this patch: n/a
Comment 16 User image u421692 2013-07-19 02:36:27 PDT
Verified fixed on:
Build: 
Firefox for Android 25.0a1(2013-07-18)
Firefox for Android 24.0a2
Firefox for Android 23.0b2

Device: LG Nexus 4
OS: Android 4.2.2

Note You need to log in before you can comment on or make changes to this bug.