Closed Bug 885974 Opened 7 years ago Closed 7 years ago

Full screen error mode when playing audio in browser

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Other
defect
Not set
normal

Tracking

(blocking-b2g:leo+)

RESOLVED DUPLICATE of bug 741102
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gecko, Assigned: daleharvey)

Details

(Whiteboard: [TD-48469] )

1. Title : [BROWSER] Full screen error mode when playing audio in browser
2. STR 
    1) Go to: http://eurd-test.lge.com/multimedia_files/Audio/mp4/index.html
    2) Open one of the mp4 audio files and try to switch to fullscreen
    - The fullscreen mode is all black -

3. Expected : There should be normal full screen UI (like for the video) 
4. Frequency Rate : 100%
Whiteboard: [TD-45752]
Target Milestone: --- → 1.1 QE3 (24jun)
Whiteboard: [TD-45752] → [TD-48469]
blocking-b2g: --- → leo+
I'm reproducing this on Nexus S with gecko b2g18 and Gaia master, looking into it.
Assignee: nobody → anthony
This bug will be resolved with bug 885349. With bug 885349, we'll use audio controls for audio files and those controls don't have full screen buttons.
Depends on: 885349
Apologies, I was wrong debugging (we can handle plugin based audio differently from natively supported formats on desktop) we dont have a dedicated music player page, its handled simliarly to video (inside a video tag), there is a bug open for this, the problem being that the fullscreen button is viewable on first load, once entering and leaving fullscreen the fullscreen button dissapears

https://bugzilla.mozilla.org/show_bug.cgi?id=741102

It might be hard to get that fixed in a short timespan (since this code is shared with firefox) however we definitely should fix the fact the controls are not visible when in full screen
No longer depends on: 885349
Taking, but happy for someone else to help on this, I dont think it will be easy
Assignee: anthony → dale
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741102
You need to log in before you can comment on or make changes to this bug.