Closed Bug 886002 Opened 9 years ago Closed 9 years ago

[settings] media storage usage bar doesn't use full width after unplugging usb cable

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, firefox26 fixed, b2g18 fixed, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE6
blocking-b2g leo+
Tracking Status
firefox26 --- fixed
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: aryx, Assigned: arthurcc)

Details

(Whiteboard: [TD-350243])

Attachments

(2 files)

Attached image screenshot of issue
Unagi with Gaia 1.1.0.0-prerelease 20130621230211

If the device is connect to a computer via USB and the media storage panel is open in the Settings app, unplugging the usb cable shows a media usage bar, but it doesn't use the full width. See the attached screenshot.
It's reprodeced in leo.
blocking-b2g: --- → leo+
Whiteboard: [TD-350243]
Hema Koka deleted the linked story in Pivotal Tracker
Priority: -- → P2
Target Milestone: --- → 1.1 QE6
Is there any update?
Flags: needinfo?(wchang)
I'll check this issue.
Assignee: nobody → arthur.chen
Flags: needinfo?(wchang)
The root cause is that `updateInfo` might be called multiple times before `getStats` returns. Simply resets the stacked bar before refreshing it. Evelyn, could you help review the change? Thanks!
Attachment #790011 - Flags: review?(ehung)
Comment on attachment 790011 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11518

I believe the patch might work, but I don't think the change is good. See my comment on Github.
Attachment #790011 - Flags: review?(ehung) → review-
Comment on attachment 790011 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11518

Comment addressed. Please help review it again, thanks!
Attachment #790011 - Flags: review- → review+
Attachment #790011 - Flags: review+ → review?(ehung)
Comment on attachment 790011 [details]
link to https://github.com/mozilla-b2g/gaia/pull/11518

r=me, looks good. Thanks!
Attachment #790011 - Flags: review?(ehung) → review+
Hi Evelyn,

Can you please confirm if this has been fixed in 1.1 (b2g18)?
Flags: needinfo?(ehung)
v1.1.0hd: 124ca7e9c1a93ceb14fd0eab85d2b1f11c0b4258
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.