[sms] SMS received again after getting the first one while system update gets unpacked

RESOLVED WONTFIX

Status

Firefox OS
Gaia::SMS
--
minor
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 766282 [details]
screenshot of issue

Unagi with Gaia 1.1.0.0-prerelease 201306202302..

While a system update was unpacking, i received a SMS and tapped the notification to open it, but nothing happened and the same happened for tapping the application icon from the homescreen (possible that the device was slow due to the unpacking). After the restart for applying the update, I responded to message and the recipient replied. The SMS app showed the new and the previous SMS by the recipient (and also showed it when it originally arrived). So it's shown twice in the conversation view.
I think this sort of bugs will come from a ack we didn't send properly in this case where the phone was very busy, or that wasn't received properly by the carrier.

I'll close this bug for now, as there is no dataloss I don't think it's worth investigating much more.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Updating used to have a lot of side of effects, both in terms of memory and CPU use but those were fixed long ago. There's good chances this was caused by the SMS app being killed during startup or something along the lines.
I'm not sure of that: remember the DB is handled on the Gecko side.

But definitely what could happen is we store the message and the phone is rebooted before sending a ack to the network.
You need to log in before you can comment on or make changes to this bug.