[socorro-crashstats] null correlations for truncated signatures in Top Crashers

RESOLVED DUPLICATE of bug 881557

Status

RESOLVED DUPLICATE of bug 881557
6 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:
1. Go to https://crash-stats-django.allizom.org/topcrasher/products/Firefox/versions/24.0a1
2. Click the Show More link next to js::PCToLineNumber(unsigned int, unsigned char*, unsigned char*, unsigned char*,...
=> null is displayed for the three types.

There are correlations for this signature:
https://crash-analysis.mozilla.com/crash_analysis/20130622/20130622_Firefox_24.0a1-core-counts.txt
https://crash-analysis.mozilla.com/crash_analysis/20130622/20130622_Firefox_24.0a1-interesting-addons.txt
https://crash-analysis.mozilla.com/crash_analysis/20130622/20130622_Firefox_24.0a1-interesting-modules.txt

I think it's caused by the truncation in Top Crashers, js::PCToLineNumber(unsigned int, unsigned char*, unsigned char*, unsigned char*,... instead of js::PCToLineNumber(unsigned int, unsigned char*, unsigned char*, unsigned char*, unsigned int*)
Hmm I think we have a dupe for this one, I remember seeing it before.
(Reporter)

Comment 2

6 years ago
(In reply to Robert Helmer [:rhelmer] from comment #1)
> Hmm I think we have a dupe for this one, I remember seeing it before.
Is bug 881557 a dupe of this one?
Yes that's it - I thought it was due to truncation too but upon investigating the full signature is being passed through (otherwise the "More" link would not show up at all). Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 881557
You need to log in before you can comment on or make changes to this bug.